Some problems during/after 1st wayland build

darxus at darxus at
Sat Sep 1 09:21:01 PDT 2012

On 09/01, Knut Petersen wrote:
> 1: misses that building weston
> will fail without a recent libwebp from

I seem to be building it successfully without libwebp.  More details?

> 2. misses that after building weston
> "make install" needs to be run as root.

When run as root, it will set weston-launch suid root.  When not run as
root, it should still work, but not set weston-launch suid root.
Instructions for then setting it manually are on that page.

> 3. Weston needs an xcursor theme to be installed and accessible via
> ~/.icons/default/index.theme, otherwise no cursor will be visible. That
> probably also should be mentioned in
> as a lot of people don´t have it on their system.

Thanks.  Do you have details of how best to do that?  (I apparently had one
installed already.)  What distro are you using that doesn't install one?

> 4. After solving problems 1-3, weston and the weston demo clients like gears
> worked fine if weston was started as an X client. Without X weston started as
> a normal user blocked keyboard and mouse, so a power button reboot or killing
> weston via ssh was necessary. Weston without started as root worked fine.

Sounds like you were running weston directly, outside of X (using the
DRM backend) instead of using weston-launch (suid root)?

Maybe that part of the instructions needs to be clearer?

I'm not really familiar with the rest of your problems.

"You will need: a big heavy rock, something with a bit of a swing to it...
perhaps Mars" - How to destroy the Earth

More information about the wayland-devel mailing list