Some problems during/after 1st wayland build

Knut Petersen Knut_Petersen at
Sat Sep 1 11:16:01 PDT 2012

>> 1:  misses that building weston
>> will fail without a recent libwebp from
> I seem to be building it successfully without libwebp.  More details?

An old version of libwebp (0.1.2-4.1.2) used by openSuSE 12.1 was found by,
but that apparently is incompatible and breaks the build. So probably a version check
needs to be added.

>> 2.  misses that after building weston
>> "make install" needs to be run as root.
> When run as root, it will set weston-launch suid root.  When not run as
> root, it should still work, but not set weston-launch suid root.
> Instructions for then setting it manually are on that page.

Yep. But a "make install" should not "work somehow but report failure".
That´s really unfriendly to scripted builds and quite unusual.

>> 3. Weston needs an xcursor theme to be installed and accessible via
>> ~/.icons/default/index.theme, otherwise no cursor will be visible. That
>> probably also should be mentioned in
>> as a lot of people don´t have it on their system.
> Thanks.  Do you have details of how best to do that?  (I apparently had one
> installed already.)  What distro are you using that doesn't install one?
Probably it would be a good idea to provide default cursor shapes.

>> 4. After solving problems 1-3, weston and the weston demo clients like gears
>> worked fine if weston was started as an X client. Without X weston started as
>> a normal user blocked keyboard and mouse, so a power button reboot or killing
>> weston via ssh was necessary. Weston without started as root worked fine.
> Sounds like you were running weston directly, outside of X (using the
> DRM backend) instead of using weston-launch (suid root)?

Yes, I used weston directly. According to the build instructions that should be possible.
Probably a permission problem, I´ll have a closer look at it.


More information about the wayland-devel mailing list