[Weston] RDP backend state

Manuel BACHMANN manuel.bachmann at open.eurogiciel.org
Thu Dec 5 07:13:43 PST 2013

Hi Michael,

Thanks for link ! I tried messing with the code too, and even directly in
FreeRDP, but it rapidly went out of control so I stopped...

I found some referencs that it worked back in April-May :
1.1 ?) so it may be related to functionality breaks in both Weston
and FreeRDP.

If you managed got an image, then maybe the "checkDescriptor" message isn't
relevant. I'll dig into this.



2013/12/5 Michael Hanselmann <public at hansmi.ch>

> On 05.12.2013 15:14, Manuel BACHMANN wrote:
> > However, it renders only a black screen, and server-side I get the
> > following messages :
> >
> > unable to checkDescriptor for <fd> failed to initialize EGL EGL does
> > not seem to work, falling back to software rendering and wl_shm
> >
> > (my EGL doesn't work, so it may be normal) I noticed I can run
> > clients, though, and they keep running until I kill them or weston
> > hangs. So it looks more like a rendering issue.
> >
> > Does someone know how to make it work, or if it's supposed to ? Is
> > it linked the error messages ?
> I filed this bug a couple of days ago:
> <https://bugs.freedesktop.org/show_bug.cgi?id=71986>. With some more
> code hacks I managed to get an image once, but the server would crash as
> soon as an input event arrived. There seem to be some severe issue with
> the code as-is, but I didn't have time to read into it in more detail.
> At least I can confirm your issue report.
> Michael


*Manuel BACHMANN Intervenant Tizen EUROGICIEL Ingénierie Groupe EUROGICIEL
- La 1ère SSAP Technopole PIBS Le Prisme Place Albert Einstein CP 1 56038
VANNES www.eurogiciel.fr <http://www.eurogiciel.fr>*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/wayland-devel/attachments/20131205/42349514/attachment.html>

More information about the wayland-devel mailing list