Rename text_model and text_model_factory?

Jan Arne Petersen jpetersen at
Tue Feb 5 12:40:11 PST 2013


On 02.02.2013 13:39, Michael Hasselmann wrote:
> Shouldn't the naming for the complementary interfaces in Weston's
> protocol/text.xml and protocol/input-method.xml be more consistent?
> For instance, there's text_model and text_model_factory interfaces in
> text.xml, but in input-method.xml, the corresponding interfaces are
> called input_method_context (~ text_model) and input_method (~
> text_model_factory).

I agree that we should find a better name for text_model.

Other name inconsistencies result from different ways the interfaces are
used. text_model_factory is a global object used by clients to create an
arbitrary amount of text_model objects on request. An input method on
the other hand cannot create input_method_context by itself but just
gets them handed out when such a context gets activated.

Jan Arne

Jan Arne Petersen
Openismus GmbH

More information about the wayland-devel mailing list