weston freezes up my system when run it in a separate VT with a normal config file

Rune Kjær Svendsen runesvend at gmail.com
Tue Feb 12 14:06:19 PST 2013


I'm trying to use weston with a config file but failing, since it freezes
up my system when I do this. I'm attaching the config file. The specified
background does exist, although the icons don't. Running weston in a gnome
terminal works fine; the background is applied correctly and it runs fine
(although the launcher icons show X's). It's only when I run it on a
separate VT the freeze occurs.

The freeze happens a different times while weston is filling the display
for the first time. If I just run weston-launcher it will freeze after the
"initializing drm backend" message in the console and stay there, although
it seems the top of the screen is also filled up somewhat it this point.
When I run it through strace, the screen gets to black with a cursor in the
upper left corner. I've also tried to have the interface appear and it
freezing immediately after that. Caps lock and num lock don't have an
effect on the LED indicators on my keyboard. Restarting weston with
Ctrl+Alt+Backspace doesn't work, Ctrl+Alt+Del doesn't work, but
Alt+SysRq+REISUB does restart the system.

I have a Radeon HD 5770 GPU, and I'm using the drivers for this, and
wayland/weston, from the xorg-edgers PPA for Ubuntu 12.10. I'm attaching
the output of stracing the freeze.
Hope you guys have some ideas on what could be wrong.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/wayland-devel/attachments/20130212/82eb210d/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: weston.ini.off
Type: application/octet-stream
Size: 985 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/wayland-devel/attachments/20130212/82eb210d/attachment-0002.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: strace-weston-launch-config-freeze.log
Type: application/octet-stream
Size: 62061 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/wayland-devel/attachments/20130212/82eb210d/attachment-0003.obj>

More information about the wayland-devel mailing list