Weston on RPi: running as non-root

Mika Boström mika.bostrom at nomovok.com
Fri Jan 4 03:47:12 PST 2013

On 01/04/13 13:30, Pekka Paalanen wrote:
> That is strange. Why does Weston need any root access for you? Are you
> perhaps running it via remote login, not local?

That could be it. I'm doing everything I can over ssh. It's worked
marvelously for intel+DRM case, so I naturally wanted the same ease with
RPi. Being able to copy-paste from terminal to terminal is something I
tend to miss quite soon. (Error messages are valuable.)

> IIRC, I have never built weston-launch for RPi, I do *not* set weston
> setuid root, and I simply run 'weston' as the 'pi' user, and it works.

With weston-launch my setup works quite nicely. I had never even tried
your approach, but that certainly works too. Verified it just a few
minutes ago.

> I wonder what we have different.

Level of expected hacking convenience, I guess. :)

 Mika Boström / mika.bostrom at nomovok.com
 Software Architect

More information about the wayland-devel mailing list