Running wayland without X running.

David Herrmann dh.herrmann at
Mon Jan 7 04:14:52 PST 2013

Hi ashjas

On Mon, Jan 7, 2013 at 11:46 AM, ashjas <ashjas at> wrote:
> Hello,
> ive just started development on wayland and am trying to run wayland without
> X server.
> I am on ubuntu machine 12.04 64bit with the following from glxinfo | grep
> -i opengl
> OpenGL vendor string: nouveau
> OpenGL renderer string: Gallium 0.4 on NV98
> OpenGL version string: 2.1 Mesa 8.0.4
> OpenGL shading language version string: 1.20
> OpenGL extensions:
> from lspci:
> 0f:00.0 VGA compatible controller: NVIDIA Corporation G98 [GeForce 8400 GS]
> (rev a1)
> secondly i couldnt run this under normal user  having sudo permissions.. so
> i got into the root mode.
> when i run ./weston-launch i endup in some graphics but that is corrupted
> one.
> and under this condition running the wayland clients like wayland-terminal
> doesnt show up anything and it doesnt give any output whatsoever.
> Any help what is wrong?
> here is the Full error log..
> -----------------------------
> root at abc-HP:/home/abc/wayland/weston/src# ./weston-launch
> Date: 2013-01-07 IST
> [15:43:44.708] weston 1.0.0
>                Bug reports to:
>                Build: 1.0.0-200-ge565b40 tests: Pass --backend so the test
> suite runs with the right modules (2012-12-14 16:34:00 -0500)
> [15:43:44.708] OS: Linux, 3.2.0-35-generic, #55-Ubuntu SMP Wed Dec 5

You should update to a newer kernel version. I know at least 2 bugs in
nouveau driver (which you use for your nvidia card) which were fixed
in linux-3.7 and which are required to make weston work.

weston doesn't need such a new kernel version itself, but the nouveau
driver is known to be buggy in these old releases.

Can you give linux-3.7.1 a try? If it still doesn't work, we can try
to find the failing piece.


More information about the wayland-devel mailing list