Unable to build Weston (configure: error: wayland-scanner is needed to compile weston).

Artsiom Anikeyenka arty.anikey at gmail.com
Wed Oct 30 14:48:46 CET 2013

Any help on that? I'm not good at GNU build tools so it's hard to me to
figure out the reason. I'll be working on that, but maybe meanwhile you'll
give me a hint?

So I just built all the prerequisites without errors but while building
Weston I got that error and I can't work it around. I've seen some related
posts on the web but it looks like it should be working fine as of now.

Also I've been removing all "easy-to-remove-warnings" which I was getting
while building wayland and its dependencies. 1 thing which is annoying the
most is the ACLOCAL environment variable which we set to build wayland
locally (per http://wayland.freedesktop.org/building.html). I've tried to
build without setting it and it worked fine. So I just thought maybe it's
redundant and is not needed while building stuff locally. If it's set as
per documentation it produces warnings due to the fact that $WLD/share/aclocal
is missing. Another workaround for it was to set:


If some1 is familiar I would appreciate related feedback a lot.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/wayland-devel/attachments/20131030/6ac2ea4a/attachment.html>

More information about the wayland-devel mailing list