Problems building Weston/demo applications on the Raspberry Pi

Silvan Jegen s.jegen at
Mon Sep 16 09:17:16 PDT 2013

> the "When adding" refers to the old version of the guide. This
> is about migrating from a old build where the configure flags
> were different.  That's what the "if you installed it before"
> meant. Granted, is not too clearly written. I guess we could now
> remove these leftovers.

That's what I suspected but I wasn't sure.

> I see we also need to fix that build guide. Your problem comes
> from --with-cairo-glesv2, which before just silently fell back to
> cairo-image, but now triggers an error.
> --with-cairo-glesv2 should simply be removed from the configure line.

Sadly, that fix was not obvious to me. Removing the flag solved the
problem, thanks a lot!

In the attached patch I removed the flag and tried to make the text less

Kind regards,


-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-Building-update-the-Raspberry-Pi-weston-section.patch
Type: text/x-diff
Size: 2320 bytes
Desc: not available
URL: <>

More information about the wayland-devel mailing list