Problems building Weston/demo applications on the Raspberry Pi

Pekka Paalanen ppaalanen at
Mon Sep 16 22:47:17 PDT 2013

On Mon, 16 Sep 2013 18:17:16 +0200
Silvan Jegen <s.jegen at> wrote:

> > the "When adding" refers to the old version of the guide. This
> > is about migrating from a old build where the configure flags
> > were different.  That's what the "if you installed it before"
> > meant. Granted, is not too clearly written. I guess we could now
> > remove these leftovers.
> That's what I suspected but I wasn't sure.
> > I see we also need to fix that build guide. Your problem comes
> > from --with-cairo-glesv2, which before just silently fell back to
> > cairo-image, but now triggers an error.
> >
> > --with-cairo-glesv2 should simply be removed from the configure line.
> Sadly, that fix was not obvious to me. Removing the flag solved the
> problem, thanks a lot!
> In the attached patch I removed the flag and tried to make the text less
> confusing.


thanks for the patch! :-)
One minor correction: it is not exactly the flag, but removing
wayland-egl.pc that makes sure that toytoolkit does not use cairo-egl.
Otherwise looks good, and the patch is an improvement even as is.


More information about the wayland-devel mailing list