[ANNOUNCE] libinput 0.4.0
Peter Hutterer
peter.hutterer at who-t.net
Tue Jun 24 23:33:15 PDT 2014
On Tue, Jun 24, 2014 at 11:25:51PM -0700, Andrea Giammarchi wrote:
> 1. Thanks! :-)
>
> 2. how is this "git patches via email" is working for you, folks? It
> happens to be in a terminal from time to time and curl -O part of a thread,
> clean up patch part, and apply it ain't usually the fastest way to try one
> ... how many things am I missing in this process? how do you apply patches
> suggested via ML or cherry pick them?
given that you originally replied to an email on wayland-devel, you should
have the patch in your inbox anyway. Just pass it to git-am and you're good
to go, provided it applies on top of your current branch (applies cleanly on
671a1442a78).
This is a fairly generic git question btw, there's probably about 5000
tutorials on google for how to do it with every email client ever written :)
Cheers,
Peter
>
> Thanks and apologies if the question is way too n00b
>
> Best Regards
>
>
> On Tue, Jun 24, 2014 at 11:16 PM, Peter Hutterer <peter.hutterer at who-t.net>
> wrote:
>
> > On Tue, Jun 24, 2014 at 11:11:41PM -0700, Andrea Giammarchi wrote:
> > > 1. congratulations!
> > >
> > > 2. I cannot build weston anymore, it complained about the RPI backend
> > > compositor first, and now it's complaining about the udev_input_destroy,
> > > libinput-seat, and a bounce of other stuff
> >
> > Patch for weston is here:
> > http://lists.freedesktop.org/archives/wayland-devel/2014-June/015590.html
> >
> > Cheers,
> > Peter
> >
> > > I'm on an Intel laptop that built weston on "pure wayland" 'till
> > yesterday,
> > > any idea what could cause this?
> > >
> > > Thanks
> > >
> > > On Tue, Jun 24, 2014 at 9:06 PM, Peter Hutterer <
> > peter.hutterer at who-t.net>
> > > wrote:
> > >
> > > > A new release of libinput, 0.4, is available.
> > > >
> > > > There are a number of API breaks in this version, every user of
> > libinput
> > > > will need some changes, sorry.
> > > >
> > > > * The logging system now works per-context instead of per library and
> > > > dropped the userdata argument.
> > > > * libinput_destroy() was changed to libinput_unref(), plus you now have
> > > > libinput_ref() too
> > > > * A couple of renames of constants for API consistency:
> > > > LIBINPUT_KEYBOARD_KEY_STATE -> LIBINPUT_KEY_STATE
> > > > LIBINPUT_POINTER_VERTICAL_SCROLL -> LIBINPUT_POINTER_SCROLL_VERTICAL
> > > > LIBINPUT_POINTER_HORIZONTAL_SCROLL ->
> > LIBINPUT_POINTER_SCROLL_HORIZONTAL
> > > > * Triggered by the logging changes, creation of udev seats is now
> > > > different.
> > > > Instead of libinput_udev_create_for_seat() use:
> > > > libinput = libinput_udev_context_create(...)
> > > > libinput_udev_assign_seat(libinput, "seat name");
> > > >
> > > > Other changes include:
> > > > * A couple of bugfixes, mainly in the touchpad code
> > > > * Absolute event coordinates are now provided in mm, not
> > device-specific
> > > > coordinates. This doesn't change anything for callers using the
> > respective
> > > > _get_transformed() function.
> > > > * ref/unref() is now available for the libinput context itself.
> > > >
> > > > The full commit shortlog is below:
> > > >
> > > > Hans de Goede (11):
> > > > Add a timer subsystem
> > > > evdev-mt-touchpad-buttons: Switch over to new timer subsystem
> > > > evdev-mt-touchpad-tap: Switch over to new timer subsystem
> > > > timer.h: Add #include libinput-util.h
> > > > Add a log_msg_va function
> > > > touchpad: tp_current_touch: Fix off by one error
> > > > test: Add touchpad 2 finger scroll test
> > > > touchpad: Avoid spurious motion event for scroll movement below
> > > > threshold
> > > > tp_post_twofinger_scroll: Move setting of t->is_pointer = false
> > up a
> > > > bit
> > > > test: Prefix litest created device names with litest
> > > > timer: Complain if a timer is set more than 5 seconds from now
> > > >
> > > > Jonas Ådahl (5):
> > > > doc: Fix spelling
> > > > event-gui: Don't drop fraction of pointer motion events
> > > > Make ref count unref/ref() functions return resulting object
> > pointer
> > > > Make context reference counted
> > > > test: Add context reference counting test
> > > >
> > > > Peter Hutterer (41):
> > > > tools: add a script to push the doxygen output to
> > freedesktop.org
> > > > Drop empty FFI_CFLAGS
> > > > test: fix compiler warning for is_debugger_attached
> > > > test: fix compiler warnings for missing prototypes
> > > > test: fix compiler warnings for missing field initializers
> > > > test: silence compiler warning for C++ build test
> > > > test: drop TEST_CFLAGS
> > > > test: add --verbose flag to litests
> > > > Mark the log function as attribute printf
> > > > test: drop unused includes for libinput-util.h
> > > > test: use check's strcmp API instead of strcmp
> > > > touchpad: log the invalid event as bug, not just as info
> > > > touchpad: Prefix tap-debugging message
> > > > touchpad: always call into the the tap state machine
> > > > test: add litest_assert_empty_queue helper function
> > > > test: add a bunch of test for click behavior on touchpads
> > > > test: add clickpad software button tests
> > > > test: Add description for the T440 synaptics touchpad
> > > > test: add a couple of top software button test
> > > > Add two doxygen cross-references for the logging functions
> > > > doc: ignore LIBINPUT_ATTRIBUTE_PRINTF in doxygen
> > > > path: log two errors as application bugs
> > > > test: fix a path test
> > > > Document the top software button behavior
> > > > tools: fix the publish-doc script
> > > > evdev: keep the absinfo struct around instead of min/max
> > > > evdev: force a resolution of 1 where no resolution is set
> > > > Change absolute and touch events to use mm as default unit
> > > > Add a function to get the size of a device
> > > > Name-space the scroll event types
> > > > tools: add a tool for GUI-based debugging
> > > > Rename KEYBOARD_KEY_STATE to KEY_STATE
> > > > test: move the interface declaration up
> > > > udev: split libinput_udev context init into two functions
> > > > Change the logging system to be per-context
> > > > Add msleep() helper function
> > > > test: add one more test for two-finger tapping
> > > > Drop the deprecated LIBINPUT_POINTER_*_SCROLL enums
> > > > Fix a few comments referring to udev_create_for_seat()
> > > > Drop the deprecated libinput_udev_create_for_seat()
> > > > configure.ac: libinput 0.4
> > > >
> > > > Stephen Chandler Paul (1):
> > > > touchpad: Fix typo in documentation
> > > >
> > > > git tag: 0.4.0
> > > >
> > > > http://wayland.freedesktop.org/releases/libinput-0.4.0.tar.xz
> > > > MD5: 60969c60e11792fab4ecaa7222f43697 libinput-0.4.0.tar.xz
> > > > SHA1: f7638a1e7f1306976211c6b11fce19e68ad2ac8e libinput-0.4.0.tar.xz
> > > > SHA256:
> > 4a6f2990f65384df012d45e5f58732fae06abb53318bf23e99c818c36184a7d1
> > > > libinput-0.4.0.tar.xz
> > > > PGP:
> > http://wayland.freedesktop.org/releases/libinput-0.4.0.tar.xz.sig
> > > >
> > > >
> > > > _______________________________________________
> > > > wayland-devel mailing list
> > > > wayland-devel at lists.freedesktop.org
> > > > http://lists.freedesktop.org/mailman/listinfo/wayland-devel
> > > >
> > > >
> >
More information about the wayland-devel
mailing list