[PATCH weston v6 3/4] Converted the config parser test to the new framework.

Pekka Paalanen ppaalanen at gmail.com
Tue Jul 7 05:08:31 PDT 2015


On Thu,  2 Jul 2015 23:36:46 -0700
"Jon A. Cruz" <jonc at osg.samsung.com> wrote:

> Signed-off-by: Jon A. Cruz <jonc at osg.samsung.com>
> ---
>  Makefile.am                |  10 +-
>  tests/config-parser-test.c | 371 +++++++++++++++++++++++++++++++++++++--------
>  2 files changed, 320 insertions(+), 61 deletions(-)
> 
> diff --git a/Makefile.am b/Makefile.am
> index 89d9e4c..42f0ed4 100644
> --- a/Makefile.am
> +++ b/Makefile.am
> @@ -1106,7 +1106,15 @@ libtest_runner_la_SOURCES =			\
>  libtest_runner_la_CFLAGS = $(AM_CFLAGS) $(COMPOSITOR_CFLAGS)
>  
>  config_parser_test_SOURCES = tests/config-parser-test.c
> -config_parser_test_LDADD = libshared.la libtest-runner.la $(COMPOSITOR_LIBS)
> +config_parser_test_LDADD =	\
> +	libshared.la		\
> +	$(COMPOSITOR_LIBS)	\
> +	libzunitc.la		\
> +	libzunitcmain.la
> +config_parser_test_CFLAGS =			\
> +	$(AM_CFLAGS)				\
> +	-Wunused \
> +	-I$(top_srcdir)/tools/zunitc/inc

Hi,

what's with the -Wunused?
We should already have -Wall -Wextra from GCC_FLAGS.

>  
>  vertex_clip_test_SOURCES =			\
>  	tests/vertex-clip-test.c		\
> diff --git a/tests/config-parser-test.c b/tests/config-parser-test.c
> index f659004..1d4e96a 100644
> --- a/tests/config-parser-test.c
> +++ b/tests/config-parser-test.c

> +/** @todo individual t1 tests should have more descriptive names. */
> +
> +ZUC_TEST_F(config_test_t1, test001)

Still todo? :-)

The rest here I browsed quickly, but seems good to me.


Thanks,
pq


More information about the wayland-devel mailing list