Compile and use rpi-backend on raspberry 2 gave always black screen after weston-launch

Pekka Paalanen ppaalanen at
Wed Sep 16 09:00:31 PDT 2015

On Tue, 15 Sep 2015 17:10:09 +0200
Fabio Fantoni <fabio.fantoni at> wrote:

> Hi, I'm trying wayland with weston on raspberry 2, the system used is 
> debian Sid plus latest kernel and drivers with rpi-update.
> Using weston from official package 1.8.0-3 with but 
> graphic seems to perform badly, so following this howto: 
> I compiled it with 
> and other raspberry specific options.
> Launching weston-launch gave me only black screen (the 
> dispmanx_offline=1 is already set), system is still accessible with ssh 
> (when I can kill weston process).
> I tried also to compile and use weston from git commit 
> ca510d06dca3e47e434a50cee105e96c9e82599c but I had also same result with 
> both normal user and root.
> I not found any warning or error in logs or other useful information for 
> now.
> Can someone help me to solve or at least debug the problem and report 
> any useful informations for solve it please?


could you post 'head config.log' from your Weston build directory,
and the log file contents from 'weston-launch &> log.txt'?

Can you exit Weston (or at least make the process exit, even if the
screen does not recover) by pressing ctrl+alt+backspace?

I'm not sure how hard it would be on your distribution, but trying
various old versions of the firmware and proprietary libs (always
use a matching set) you might find a version that works, in case
this is a firmware issue.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 811 bytes
Desc: not available
URL: <>

More information about the wayland-devel mailing list