Compile and use rpi-backend on raspberry 2 gave always black screen after weston-launch

Fabio Fantoni fabio.fantoni at
Tue Sep 15 08:10:09 PDT 2015

Hi, I'm trying wayland with weston on raspberry 2, the system used is 
debian Sid plus latest kernel and drivers with rpi-update.
Using weston from official package 1.8.0-3 with but 
graphic seems to perform badly, so following this howto: I compiled it with and other raspberry specific options.
Launching weston-launch gave me only black screen (the 
dispmanx_offline=1 is already set), system is still accessible with ssh 
(when I can kill weston process).

I tried also to compile and use weston from git commit 
ca510d06dca3e47e434a50cee105e96c9e82599c but I had also same result with 
both normal user and root.
I not found any warning or error in logs or other useful information for 
Can someone help me to solve or at least debug the problem and report 
any useful informations for solve it please?

Thanks for any reply and sorry for my bad english.

More information about the wayland-devel mailing list