Compile and use rpi-backend on raspberry 2 gave always black screen after weston-launch

Fabio Fantoni fabio.fantoni at
Thu Sep 24 07:52:06 PDT 2015

Il 23/09/2015 16:53, Derek Foreman ha scritto:
> On 17/09/15 09:16 AM, Fabio Fantoni wrote:
>> Il 17/09/2015 14:15, Pekka Paalanen ha scritto:
>>> On Thu, 17 Sep 2015 11:13:19 +0200
>>> Fabio Fantoni <fabio.fantoni at> wrote:
>>>> Il 16/09/2015 18:00, Pekka Paalanen ha scritto:
>>>>> On Tue, 15 Sep 2015 17:10:09 +0200
>>>>> Fabio Fantoni <fabio.fantoni at> wrote:
>>>>>> Hi, I'm trying wayland with weston on raspberry 2, the system used is
>>>>>> debian Sid plus latest kernel and drivers with rpi-update.
>>>>>> Using weston from official package 1.8.0-3 with but
>>>>>> graphic seems to perform badly, so following this howto:
>>>>>> I compiled it with
>>>>>> and other raspberry specific options.
>>>>>> Launching weston-launch gave me only black screen (the
>>>>>> dispmanx_offline=1 is already set), system is still accessible with
>>>>>> ssh
>>>>>> (when I can kill weston process).
>>>>>> I tried also to compile and use weston from git commit
>>>>>> ca510d06dca3e47e434a50cee105e96c9e82599c but I had also same result
>>>>>> with
>>>>>> both normal user and root.
>>>>>> I not found any warning or error in logs or other useful
>>>>>> information for
>>>>>> now.
>>>>>> Can someone help me to solve or at least debug the problem and report
>>>>>> any useful informations for solve it please?
>>>>> Hi,
>>>>> could you post 'head config.log' from your Weston build directory,
>>>>> and the log file contents from 'weston-launch &> log.txt'?
>>>> Thanks for your reply.
>>>> See attachments, full config.log and build log of 1.8.0 build of debian
>>>> package changing configure parameters based on raspberry wiki page.
>>>> weston.log is the output of weston-launch.
>>>> weston.ini have config of the test, plus the the line commented of first
>>>> test from official debian package working but graphic seems to perform
>>>> badly.
>>> Arguments to ./configure seem ok.
>>>>> Can you exit Weston (or at least make the process exit, even if the
>>>>> screen does not recover) by pressing ctrl+alt+backspace?
>>>> Pressing ctrl+alt+backspace exit correctly from weston with black screen
>>>> only.
>>> So input works, good. Only gfx output is missing.
>>> Your weston log looks ok, with one strange thing: "mesg: ttyname
>>> failed: Inappropriate ioctl for device". I wonder where that comes from.
>>>>> I'm not sure how hard it would be on your distribution, but trying
>>>>> various old versions of the firmware and proprietary libs (always
>>>>> use a matching set) you might find a version that works, in case
>>>>> this is a firmware issue.
>>>> I automatically updated them with rpi-update, I don't have good
>>>> experience on arm, I did only few tests (mainly on raspberry pi 2), any
>>>> advice is appreciated.
>>> If you look into the documentation of rpi-update, you should find how
>>> to specify old versions:
>>> Unfortunately I cannot tell what a good firmware revision might be.
>>> Also, I don't think I've tried Weston on rpi2, only on rpi1. They
>>> probably shouldn't differ in this respect, but who knows.
>>> Maybe someone who actually has Weston/rpi-backend working could tell
>>> his firmware revision. The distribution shouldn't matter as long as
>>> rpi-update updates the libraries too.
>>> Actually you might want to check if there are multiple copies of e.g.
>>>,, or such. Using a wrong
>>> version compared to your firmware might cause problems. Also try the
>>> demos from
>>> If things like hello_dispmanx don't show up, then the problem is with
>>> the firmware or the proprietary libs for sure.
>>> Thanks,
>>> pq
>> Thanks for you reply.
>> I did some other tests, trying latest update with kernel 4.1.7 gave same
>> result, I tried also commit 33a6707cf1c96b8a2b5dac2ac9dead590db9fcaa
>> (latest 3.18) but also in this case same result (black screen) and
>> nothing useful in logs :(
>> I tried to build and run hello_dispmanx.bin and seems working: I see a
>> blue, green and redsquares at the center of the screen.
>> Is there someone that use raspberry 2 with wayland/weston that can give
>> me a commit of a working firmware please?
> Sorry, in order to do that I'd be doing what Pekka already suggested you
> do (try different versions until one works)

Thanks for reply, I already tried 6 different versions (not near 
commits) plus recent commits from start of testing including another 
update today but nothing works :(

> I've actually never had great success with the rpi backend on my rpi2.
> online mode was fine until you open too many windows (as expected).
> offline mode was 30fps until you opened too many windows, then the
> device locked up.
> I'm fairly confident that must be a firmware/support library problem.  I
> didn't bother trying different revisions.
> Ultimately, I think the rpi renderer will likely be removed entirely,
> see for a work in progress DRM
> driver for rpi/rpi2.
> We're using this as part of a tizen image for rpi2
> (, and
> it works reasonably well even in its current state.

I didn't try Tizen and I don't know if is possible do a low cost spice 
thin client with raspberry pi 2 (my mainly target for now).

For try VC4 I must rebuild linux from , mesa from 
upstream and change /boot/config.txt as wiki told or I must also 
recompile wayland, weston (instead default debian packages without 
rpi-backend) and/or other components not mentioned in VC4 wiki page?
In mesa configure of wiki I saw:
I must include also wayland, right?

Thanks for any reply and sorry for my bad english.

> I suspect once the drm vc4 driver is available in raspbian, Pekka and I
> will race to see who can delete the rpi backend from weston first. ;)
> Thanks,
> Derek

More information about the wayland-devel mailing list