How to run Weston on specific devices?

me at me at
Thu Jan 7 04:36:42 PST 2016

On 07.01.16 13:14, Pekka Paalanen wrote:
 >> But I want to run Weston on a gfx card other than X is running on. I
 >> have 2 gfx cards.
 > Ok, then you are left with the VT management issues, which I didn't
 > mention yet. I don't actually know what is needed to (not) do when
 > using a gfx card that is not used for the console. I believe this is a
 > use case Weston hasn't considered yet.
 > VT management issues might also be responsible for the "freeze" you
 > described.
I just run Xorg on "seat1" with "-sharevts" and "-novtswitch" and don't 
give it much thought. I use VTs on "seat0" only.

>> On 07.01.16 10:42, Pekka Paalanen wrote:
>>>>> Have you tried using the --seat command line argument to make Weston's
>>>>> DRM-backend pick a seat other than the default "seat0"?
>>>> Okay, Weston drives "seat1" if given the option "--seat=seat1" and no
>>>> configuration file. But "seat0" where I start Weston freezes until
>>>> Weston terminates.
>>> What do you mean by "freeze"? Black screen? Blank screen? Desktop, but
>>> no reaction to any input? Does the clock update? Got a log from that,
>>> does it open any input devices then?
>> I run "weston-launch" from a virtual terminal/agetty/login/bash. The
>> screen does not change, the cursor does not blink. No reaction. I don't
>> understand what log should I provide.
> Weston stdout and stderr are generally referred to as Weston's log.
> There is also a --log command line option, but that catches only
> Weston's own messages.
Date: 2016-01-07 EET
[14:11:23.025] weston 1.9.0
                Bug reports to:
                Build: 1.8.93-2-gb05cdb8 bump to version 
1.9.0 for the official release (2015-09-21 18:11:26 -0700)
[14:11:23.026] OS: Linux, 4.3.3-2-ARCH, #1 SMP PREEMPT Wed Dec 23 
20:09:18 CET 2015, x86_64
[14:11:23.026] Using config file './weston.ini'
[14:11:23.027] Loading module '/usr/lib/weston/'
[14:11:23.169] Output repaint window is 7 ms maximum.
[14:11:23.169] initializing drm backend
device-enumerator: scan all dirs
   device-enumerator: scanning /sys/bus
   device-enumerator: scanning /sys/class
[14:11:23.171] using /dev/dri/card1
[14:11:23.171] Loading module '/usr/lib/weston/'
[14:11:23.601] EGL client extensions: EGL_EXT_client_extensions
                EGL_EXT_platform_base EGL_EXT_platform_wayland
                EGL_EXT_platform_x11 EGL_KHR_client_get_all_proc_addresses
[14:11:23.601] warning: EGL_EXT_swap_buffers_with_damage not supported. 
Performance could be affected.
device-enumerator: scan all dirs
   device-enumerator: scanning /sys/bus
   device-enumerator: scanning /sys/class
[14:11:23.616] input device 'USB USB Keyboard', /dev/input/event1 is 
tagged by udev as: Keyboard
[14:11:23.616] input device 'USB USB Keyboard', /dev/input/event1 is a 
[14:11:23.617] input device 'USB USB Keyboard', /dev/input/event2 is 
tagged by udev as: Keyboard
[14:11:23.617] input device 'USB USB Keyboard', /dev/input/event2 is a 
[14:11:23.618] input device 'ImPS/2 Generic Wheel Mouse', 
/dev/input/event8 is tagged by udev as: Mouse
[14:11:23.618] input device 'ImPS/2 Generic Wheel Mouse', 
/dev/input/event8 is a pointer caps
[14:11:23.662] EGL version: 1.4 (DRI2)
[14:11:23.662] EGL vendor: Mesa Project
[14:11:23.662] EGL client APIs: OpenGL OpenGL_ES OpenGL_ES2
[14:11:23.662] EGL extensions: EGL_EXT_buffer_age 
                EGL_KHR_create_context EGL_KHR_get_all_proc_addresses
                EGL_KHR_gl_renderbuffer_image EGL_KHR_gl_texture_2D_image
                EGL_KHR_gl_texture_cubemap_image EGL_KHR_image
                EGL_KHR_image_base EGL_KHR_image_pixmap
                EGL_KHR_surfaceless_context EGL_MESA_configless_context
                EGL_MESA_drm_image EGL_MESA_image_dma_buf_export
[14:11:23.662] GL version: OpenGL ES 2.0 Mesa 11.1.0
[14:11:23.662] GLSL version: OpenGL ES GLSL ES 1.0.16
[14:11:23.662] GL vendor: nouveau
[14:11:23.662] GL renderer: Gallium 0.4 on NV4C
[14:11:23.662] GL extensions: GL_EXT_blend_minmax GL_EXT_multi_draw_arrays
                GL_OES_depth24 GL_OES_element_index_uint
                GL_OES_fbo_render_mipmap GL_OES_mapbuffer GL_OES_rgb8_rgba8
                GL_OES_stencil8 GL_OES_texture_3D GL_OES_texture_npot
                GL_OES_EGL_image GL_OES_depth_texture
                GL_OES_get_program_binary GL_APPLE_texture_max_level
                GL_EXT_discard_framebuffer GL_EXT_read_format_bgra
                GL_NV_fbo_color_attachments GL_OES_EGL_image_external
                GL_OES_EGL_sync GL_OES_vertex_array_object
                GL_ANGLE_texture_compression_dxt5 GL_EXT_unpack_subimage
                GL_NV_draw_buffers GL_NV_read_buffer GL_NV_read_depth
                GL_NV_read_depth_stencil GL_NV_read_stencil 
                GL_EXT_map_buffer_range GL_KHR_debug 
[14:11:23.662] GL ES 2 renderer features:
                read-back format: BGRA
                wl_shm sub-image to texture: yes
                EGL Wayland extension: yes
[14:11:23.662] Chosen EGL config details:
                RGBA bits: 8 8 8 0
                swap interval range: 0 - 0
[14:11:23.662] Failed to initialize backlight
[14:11:23.662] Output VGA-2, (connector 28, crtc 25)
                mode 1024x768 at 60.0, current
                mode 800x600 at 60.3
                mode 800x600 at 56.2
                mode 848x480 at 60.0
                mode 640x480 at 59.9
[14:11:23.663] Compositor capabilities:
                arbitrary surface rotation: yes
                screen capture uses y-flip: yes
                presentation clock: CLOCK_MONOTONIC, id 1
[14:11:23.663] Loading module '/usr/lib/weston/'
[14:11:23.663] launching '/usr/lib/weston/weston-keyboard'
[14:11:23.664] launching '/usr/lib/weston/weston-desktop-shell'
[14:11:23.736] Warning: computed repaint delay is insane: -1392723845 msec
[14:11:23.921] unexpectedly large timestamp jump (from 12282989 to 

More information about the wayland-devel mailing list