[PATCH 6/7] compositor-drm: Renaming of things

Daniel Stone daniel at fooishbar.org
Tue Mar 22 08:49:11 UTC 2016


On 21 March 2016 at 16:41, Miguel A. Vico <mvicomoya at nvidia.com> wrote:
> In preparation for follow-on changes to support frame presentation
> through EGLDevice+EGLOutput, this change includes the following:
>   - Rename drm_backend::format   to gbm_format
>   - Rename drm_output::format    to gbm_format
>   - Rename drm_output::surface   to gbm_surface
>   - Rename drm_output::cursor_bo to gbm_cursor_bo

I think this is actually an improvement even without Streams.

Reviewed-by: Daniel Stone <daniels at collabora.com>


More information about the wayland-devel mailing list