Touchpad on an XPS 13 9360

Michael Wisniewski mikewiz38 at
Thu Apr 13 21:14:05 UTC 2017


First, I hope that this is the correct place to post, as I'm not really a
developer, but don't know where else to go.  I'm running Ubuntu Gnome 16.10
and using the libinput that is packaged with Ubuntu.  I *think* It's the
1.6 version, but I really don't know and that's actually one of my

My first question do you find which version of libinput you're
using?  The package manager shows a 1.4.3-0ubuntu1, while the object's name
is "" and xinput --list shows version 1.6.2.

I then tried to compile the latest libinput version from the git repo and
follow the instructions on the building libinput wiki page, but that
version still shows 1.6.2.

Ultimately, my issue is trying to get my touchpad to work better on this
laptop.  Under XUbuntu, I'm using the synaptics driver, which works good,
but still has some small nuances.  It also seems like the Synaptics driver
is going away, which is why I'm looking at moving over to libinput.

Unfortunately though, with libinput, I can adjust the acceleration but not
the sensitivity.  I would say that everything works OK until you try to
make small movements to pinpoint something, then the cursor jumps around a
bit.  It then gets frustrating and annoying.

I've tried to play around with the xinput set-props but I just can't get
the right combination.  I've also seen a few patches that were applied to
help others out, but considering I can't get Ubuntu to recognize the 1.7
version I downloaded, I'm not exactly sure I'd be able to patch and use
that version.

Any help is appreciated.  I know it's not much to go on as I don't have any
dumps but I'm more than happy to work with everybody in order to get this
solved and to help others.

Thank you in advanced...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the wayland-devel mailing list