Unable to run X-clients over Weston through XWayland

Pekka Paalanen ppaalanen at gmail.com
Mon Dec 2 10:43:04 UTC 2019

On Mon, 2 Dec 2019 13:53:24 +0530
"Devashish Tiwari" <devashish at cdot.in> wrote:

> SDK version. But I was optimistic that Weston could be run with
> xwayland on this EVM. And after adding some final dependencies, I
> think it's good now. I have attached copied logs at the end of this
> email.
> However, I wanted to ask if there are some sample
> X-clients/applications which I could run to check if weston+xwayland
> is really working or not. I tried to cross-compile xeyes for armhf
> and tried to run it,
> but it showed following error:
> root at am57xx-evm:/mnt# ./xeyes 
> Error: Can't open display:
> Am I missing something else here, that is required to run X-apps? Any
> Environment Variable or so?


yes, the usual DISPLAY as always with any X11 stuff anywhere. Weston
will set it, so all processes that inherit their environment from
Weston will have it readily set, e.g. the launchers you can set up in

Do note that xeyes specifically will only react to mouse when the
pointer is on any X11 window. The X server cannot see any Wayland
windows and cannot eavesdrop on input either.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://lists.freedesktop.org/archives/wayland-devel/attachments/20191202/d0befac8/attachment-0001.sig>

More information about the wayland-devel mailing list