Unable to run X-clients over Weston through XWayland

Devashish Tiwari devashish at cdot.in
Tue Dec 3 06:56:59 UTC 2019


It seems like Weston with Xwayland is still not working for me. Despite of the positive xserver-related prints I get in weston.log file :


[02:43:02.573] Loading module '/usr/lib/libweston-2/xwayland.so'
[02:43:02.587] Registered plugin API 'weston_xwayland_v1' of size 16
[02:43:02.587] Registered plugin API 'weston_xwayland_surface_v1' of size 8
[02:43:02.587] xserver listening on display :0
[02:43:02.587] launching '/usr/libexec/weston-desktop-shell'


I am not able to run any X-client within weston-terminal. My $DISPLAY variable is set to  ":0" by default, but as I run any X-client (xclock, xconsole, xhost, xcalc etc.) or any X11 basic sample code I get following error:

Error: Can't open display: :0

I don't know why this error keeps popping up. Can you help?



On Mon, 2 Dec 2019 12:43:04 +0200, Pekka Paalanen wrote

On Mon, 2 Dec 2019 13:53:24 +0530 
 "Devashish Tiwari" <devashish at cdot.in> wrote:

 > SDK version. But I was optimistic that Weston could be run with 
 > xwayland on this EVM. And after adding some final dependencies, I 
 > think it's good now. I have attached copied logs at the end of this 
 > email. 
 > However, I wanted to ask if there are some sample 
 > X-clients/applications which I could run to check if weston+xwayland 
 > is really working or not. I tried to cross-compile xeyes for armhf 
 > and tried to run it, 
 > but it showed following error: 
 > root at am57xx-evm:/mnt# ./xeyes 
 > Error: Can't open display: 
 > Am I missing something else here, that is required to run X-apps? Any 
 > Environment Variable or so?


 yes, the usual DISPLAY as always with any X11 stuff anywhere. Weston 
 will set it, so all processes that inherit their environment from 
 Weston will have it readily set, e.g. the launchers you can set up in 

 Do note that xeyes specifically will only react to mouse when the 
 pointer is on any X11 window. The X server cannot see any Wayland 
 windows and cannot eavesdrop on input either.



Thanks & Regards,

Devashish Tiwari 
Fault Tolerance 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/wayland-devel/attachments/20191203/c0962afa/attachment.html>

More information about the wayland-devel mailing list