Unable to run X-clients over Weston through XWayland

Devashish Tiwari devashish at cdot.in
Wed Dec 11 08:37:50 UTC 2019


Thanks for your response.

I am still not sure about how to run X-clients (xeyes, xcalc, xclock etc) on Weston running with xwayland module.

I did:

 export DISPLAY=':0'

and tried to run Xclient. But I am getting the same error:

Error: Can't open display: :0

I don't know what's the reason behind this, even though Weston is listening on the X11 socket, as I am getting "xserver listening on display :0" in weston.log

Can you point me at some basic X-client/app which I'd be able to run successfully on my weston+xwayland environment?

PS I just want to make sure that Weston with xwayland really works or else I'd have cross-compile whole Xorg server just to run X-clients on my EVM.



On Tue, 3 Dec 2019 10:54:47 +0200, Pekka Paalanen wrote

On Tue, 3 Dec 2019 12:26:59 +0530 
 "Devashish Tiwari" <devashish at cdot.in> wrote:

 > Hello, 
 > It seems like Weston with Xwayland is still not working for me. 
 > Despite of the positive xserver-related prints I get in weston.log 
 > file : 

 > --------------- 
 > [02:43:02.573] Loading module '/usr/lib/libweston-2/xwayland.so' 
 > [02:43:02.587] Registered plugin API 'weston_xwayland_v1' of size 16 
 > [02:43:02.587] Registered plugin API 'weston_xwayland_surface_v1' of size 8 
 > [02:43:02.587] xserver listening on display :0 
 > [02:43:02.587] launching '/usr/libexec/weston-desktop-shell' 
 > ---------------

 > I am not able to run any X-client within weston-terminal. My $DISPLAY 
 > variable is set to  ":0" by default, but as I run any X-client 
 > (xclock, xconsole, xhost, xcalc etc.) or any X11 basic sample code I 
 > get following error: 
 > Error: Can't open display: :0


 Weston launches Xwayland on-demand. The log snippet above does not mean 
 Xwayland was already started, it's just Weston listening on the X11 
 socket. Check your Weston stdout/stderr after you failed to launch an 
 X11 app.

 You can also 'strace' your X11 app to see if it e.g. doesn't have the 
 permission to the open the socket for some strange reason.



Thanks & Regards,

Devashish Tiwari 
Fault Tolerance 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/wayland-devel/attachments/20191211/9a36b3d3/attachment.htm>

More information about the wayland-devel mailing list