Unable to run X-clients over Weston through XWayland

Pekka Paalanen ppaalanen at gmail.com
Wed Dec 11 10:10:31 UTC 2019

On Wed, 11 Dec 2019 14:07:50 +0530
"Devashish Tiwari" <devashish at cdot.in> wrote:

> Hi,
> Thanks for your response.
> I am still not sure about how to run X-clients (xeyes, xcalc, xclock
> etc) on Weston running with xwayland module.
> I did:
>  export DISPLAY=':0'
> and tried to run Xclient. But I am getting the same error:
> Error: Can't open display: :0
> I don't know what's the reason behind this, even though Weston is
> listening on the X11 socket, as I am getting "xserver listening on
> display :0" in weston.log


then I am equally at loss, too.

Please run the X11 app with 'strace' and see what exactly fails.

> Can you point me at some basic X-client/app which I'd be able to run
> successfully on my weston+xwayland environment?

You already tried them, and I can't see anything wrong in what you

Except, you didn't say Weston logging a message where it actually
succeeded in launching Xwayland. Something like this:

[12:08:05.666] xserver listening on display :1
[12:08:11.198] Spawned Xwayland server, pid 26539
[12:08:11.475] xfixes version: 5.0
[12:08:11.491] created wm, root 924

Those last three lines indicate success.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://lists.freedesktop.org/archives/wayland-devel/attachments/20191211/006d39b6/attachment-0001.sig>

More information about the wayland-devel mailing list