[ANNOUNCE] libinput 1.13.901
Peter Hutterer
peter.hutterer at who-t.net
Fri Jul 19 02:24:17 UTC 2019
The first RC for libinput 1.14 is now available.
We have new and improved thumb detection for touchpads, thanks to Matt
Mayfield. On Clickpad devices this should make interactions where a thumb is
resting on the touchpad or dropped during an interaction more reliable. A
summary of the changes can be found here:
https://who-t.blogspot.com/2019/07/libinputs-new-thumb-detection-code.html
The Dell Canvas Totem is now supported by libinput. It is exposed as a new
tool type through the tablet interface along with two new axes. Note that
this is only low-level support, the actual integration of the totem needs
Wayland protocol changes and significant changes in all applications that
want to make use of it. A summary of the changes can be found here:
https://who-t.blogspot.com/2019/06/libinput-and-dell-canvas-totem.html
Touch-capable tablets now tie both devices together for rotation. If you set
the tablet to left-handed, the touchpad will be rotated along with the
tablet. Note that this does not affect the left-handed-ness of the touchpad,
merely the rotation.
Tablet proximity out handling for tablets that are unreliably sending
proximity out events is now always timeout-based. It is no longer necessary
to add per-device quirks to enable this feature and it is completely
transparent on devices that work correctly anyway. A summar of the
changes can be found here:
https://who-t.blogspot.com/2019/06/libinput-and-tablet-proximity-handling.html
Tablets that send duplicate tools (BTN_TOOL_PEN and BTN_TOOL_ERASER) now
ignore the latter. This is an intermediate fix only but at least makes those
tablets more usable than they are now. Issue #259 is the tracker for this
particular behaviour if you are affected by it.
The handling of kernel fuzz has been slightly improved. Where our udev rule
fails to reset the fuzz on the kernel device, we disable the hysteresis and
rely on the kernel now to handle it. Previously our hysteresis would take
effect on top of the kernel's, causing nonresponsive behaviour.
Note to distribitors: the python-evdev dependency has been dropped, the
tools that used it are now using python-libevdev instead.
And of course a random assortment of fixes, improvements, etc. Many thanks
to all contributors and testers.
As usual, the git shortlog is below.
Alex Flowers (1):
quirks: add a quirk for the Lenovo X1 Yoga 1st gen
Benjamin Tissoires (8):
CI: remove the bootstrapping stage
CI: heavily rework the container creation
CI: clean up all but the correct tag
CI: use the template for fedora
CI: use templates for Arch
CI: use templates for Ubuntu
CI: do not rebuild the image for regular MR or pushes
CI: simplify the logic for rebuilding the containers
Ian Douglas Scott (1):
Enable ModelTabletNoProximityOut quirk on HP Spectre 13-ap0xxx
Jason Gerecke (3):
fallback: Fix ubsan runtime error
test: Clean up memory leaks
test: abort when no default value is available for an axis
Lubomir Rintel (1):
quirks: speed up the TrackPoint on the IBM USB UltraNav keyboard a bit
Matt Mayfield (7):
touchpad: basic thumb detection within gestures
gestures: improve scroll responsiveness for vertically aligned touches
gestures: improvements to pinch detection
gestures: Improve thumb detection, allow one finger scroll
touchpad: revamp thumb detection
touchpad: don't detect speed-based thumbs if there's already a thumb
touchpad: stricter thumb detection if no pressure/size
Michael Forney (6):
Remove semicolons after function definitions
Avoid unnecessary VLAs
Avoid case ranges in switch statement
Use bitwise test instead of __builtin_popcount
Don't return expression in function returning void
Replace one more __builtin_popcount with bitwise test
Peter Hutterer (152):
meson.build: add the toshiba quirks file to the file list
quirks: add a test to make sure all our quirks files are listed in meson
tools: record: increase value size to 6 digits
tools: switch measure-fuzz to use python-libevdev
tools: switch measure-touch-size to python-libevdev
tools: switch measure-touchpad-pressure to python-libevdev
tools: switch measure-touchpad-tap to python-libevdev
meson.build: bump to 1.13.900
test: drop some unnecessary extern declarations
doc/api: add since tags to all functions after 1.0
doc/api: minor style changes
tablet: move the current tool bits into a substruct
tablet: log a bug when a tablet switches between tools directly
tablet: always enable the proximity out quirk
tablet: add missing linebreak after error message
tablet: fix some code alignment
tools: use American spelling for 'unrecognized'
tools: fix waiting for the tool to quit in the options test
test: actually filter events when writing to udev
test: filter BTN_TOOL_PEN correctly for the mouse tool tests
test: fix the hid4800 device's prox out serial number
test: reduce some touch sequences to avoid tablet timeouts
tablet: tighten the test for tablet button releases on proximity out
tablet: add a debugging message when we force a proximity out
test: add proximity timeout delay to a tablet test
tablet: move tablet tool change processing to tablet_flush
test: use identifiable shortnames for the Intuos5 devices
touchpad: rotate the touch part of tablets
test: update valgrind suppressions for a glib leak
CI: switch from Fedora 28 to Fedora 30
CI: update Ubuntu from 18.04 to 19.04
Revert "Reduce button scroll timeout to 38ms"
tools: we don't need a core file for failed option parser tests
meson: group all tests under suite names
tools: drop the valgrind check in the option-parsing test
test: replace the USING_VALGRIND env with the valgrind.h header
test: return 77 for skip when we're not running a test
test: skip the backtrace under valgrind
CI: use meson test instead of ninja test
test: drop the SKIP_LIBINPUT_TEST_RUNNER environment variable
test: fix a bunch of tests expecting BTN_TOOL_TRIPLETAP
test: fix the wacom bamboo touch device
tablet: indentation fix
tablet: add an extra debug message
touchpad: don't check libwacom if we're not tagged as tablet touchpad
touchpad: fix two debug messages to have the same prefix as the rest
test: make the test case failure output easier to select
fallback: make a debug log prefix more consistent
test: assign ID_INPUT_TABLET to the bamboo/intuos5 touchpad parts
test: fix a typo in the test device name
tablet: don't disable the proximity quirk on good sequences
tools: add --apply-to to debug-events and debug-gui
tablet: lock the tablet rotation to the touchpad rotation
touchpad: lock the touchpad rotation to the tablet rotation
test: add test cases for tablet/touchpad left-handed rotation locks
test: split a test up into events vs processing
test: always set CK_FORK=no under valgrind
test: make all tap tests use the "tap" group prefix
test: allow for a LITEST_JOBS environment variable
Abstract libwacom database initialization into a single place
test: don't treat a signal exit as success
gitlab CI: switch F29 special builds to F30
quirks: handle ID_INPUT_KEY as udev keyboard match
test: add a missing blank line
quirks: add trackpoint integration attribute
Warn if NDEBUG is defined
test: drop two unreachable statements
doc/api: more CSS styling
test: force the litest feature enum to be 8 bytes or more
tablet: add a the Totem tool type to the tablet interface
Add a new dispatch interface for the Dell Canvas Totem
udev: only change the fuzz on touchpads and touchscreens
test: fix an intermitted failing test
test: abort if our device didn't initialize
path: drop the separate header, not necessary
udev: don't init the quirks until we checked all arguments
path: factor out the seat creation into a helper function
path: initialize the quirks context after error checking
path: add helper function to destroy a device
test: add the 24HDT pad to the custom device group
test: swap a few litest_assert() calls for their more precise cousins
test: remove a duplicate check
tools: display tablet and tablet pad buttons when pressed
tools: handle pad strip/ring events in the debug-gui
tools: describe the various debug-gui features in the man page
test: replace the double assert macros with proper checks
test: adjust the relative pointer motion test for low-dpi devices
test: remove invalid GOTO in udev rule
test: auto-generate the udev rules
test: only write one single rules file for our device quirks
test: don't make timer offset errors fatal in gdb
tablet: fix double proximity out on slow proximity out pens
quirk: drop the ModelTabletNoTilt quirk
tablet: disable the forced proximity out for the Dell Canvas pen
touchpad: slightly change a debug message
test: rename/fix/move thumb tests
test: fix the clickfinger thumb test
test: add another test for thumb movements
test: remove two spurious SYN_REPORTs
test: don't go into the thumb area for the 3fg clickfinger distance check
test: don't form a pinch gesture for the clickfinger distance test
test: fix initial coordinates for synaptics tripletap quirk
test: replace a touch move with a timeout
test: change touchpad 2fg no-motion test to move both fingers simultaneously
test: move the fingers closer together for the empty-slot test
test: fix button area scroll test to not be a pinch
test: use an enum for the cardinals
test: fix the slot swap test
test: avoid a pointer jump when testing for the slot continuation
test: fix the slot swap test again
doc: note that libinput measure is a separate package
tools: improve the error messages for measure touch-size/touchpad-pressure
Revert "udev: only change the fuzz on touchpads and touchscreens"
udev: rename libinput-model-quirks rules to libinput-fuzz-override.rules
udev: only change the fuzz on touchpads and touchscreens (v2)
tools: skip debug-gui option testing if the debug-gui is disabled
If we never initialized the libwacom database, don't check the refcount
evdev: only extract the fuzz for touchpads and touchscreens
test: disable coredumps for the selftest
meson: increase the test time for the selftest suite
tools: return 77 if gtk_init() fails in the debug-gui
meson: force litest to use the right udev rules
evdev: when the kernel fuzz is nonzero, set ours to zero
quirks: rename the cyapa quirks file to cypress
quirks: add touchpad range for cypress touchpads
test: one O_NONBLOCK is enough
test: drop the litest feature enum, make it normal bits instead
test: fix two coverity warnings
test: fix an always-true check for udev properties
meson.build: move the leftover udev rule check up
test: use the default job control for --filter-groups
meson: run the test suite per group
doc/user: fix a typo
touchpad: reduce state debugging output by only logging changed states
touchpad: rename the scroll timeout define, drop the pinch one
touchpad: add a helper function for checking thumb state
touchpad: add a helper function for counting touches for gestures
touchpad: move tp_init_thumb and tp_thumb_detect to the thumb file
touchpad: add helper function for setting the thumb state
touchpad: explicitly start with detect_thumbs as false
touchpad: add helper function to reset a thumb's state
touchpad: move the speed-thumb detection code to the thumb helper file
touchpad: extract some bits of thumb detection into helper functions
touchpad: rename the thumb detection methods
gestures: fast-track scroll/swipe detection when gestures are off
touchpad: add a helper function for supressing a thumb
touchpad: only log edge scroll state changes when the state actually changes
test: only run the speed tests for clickpads
test: only run the speed finger tests when the touchpad has thumb detection
test: make the touchpad size the only check for thumb detection
doc/user: add documentation for the new thumb detection
libinput 1.13.901
René Genz (1):
doc/user: fix some typos
Sebastian Krzyszkowiak (3):
quirks: add a new Apple vendor ID for Bluetooth devices
evdev-mt-touchpad-buttons: use a model quirk instead of vendor ID to identify Apple devices
CI: update arch package list
Tobias Stoeckmann (1):
Removed whitespace from filename.
Vladyslav Shtabovenko (1):
Introduce Dell Latitude 5480 trackpoint multiplier. Otherwise the
Zach Moazeni (1):
Better Thinkpad T480 trackpoint multiplier
pixl (1):
Fixed a grammar error
timrichardson (1):
X230 trackpoint quirk
git tag: 1.13.901
https://www.freedesktop.org/software/libinput/libinput-1.13.901.tar.xz
MD5: 0bd89573c63770082332878e903d80dc libinput-1.13.901.tar.xz
SHA1: 957d1ce35fb4e7c9bca0fc5f7da9fef76c0006e8 libinput-1.13.901.tar.xz
SHA256: f4e8b77a5d25000d5b2621267050134e7297485126bab26e743232554a994a96 libinput-1.13.901.tar.xz
SHA512: 3bd391c971b6cd00a8d3d087107bb4aa15213051343ef57cc373f6a2e1dfe2bbd00c862e77defec7c5dd2f363ac44e83a4a62c72fbdaedd3b1fa0ba7c9af5d98 libinput-1.13.901.tar.xz
PGP: https://www.freedesktop.org/software/libinput/libinput-1.13.901.tar.xz.sig
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/wayland-devel/attachments/20190719/a1045fb9/attachment.sig>
More information about the wayland-devel
mailing list