[Xcb] Status of XCB and howto begin

Alexander Botero alex.botero at gmail.com
Sun Feb 5 10:01:12 PST 2006


And many thanks for your (all) help.  I managed to compile xcb with success,
but have still a few minor problems.

I can compile all the demos and tests in .../xcb-demo.  It shows no
compilation errors.  But when running the programs, they just print a lot of
garbage on the terminal window and exit with a segmentation fault.


$ pwd

$ ./xcb-test

/Segmentation fault
---------------------------------- -----------------------------------------

ldd shows:

$ ldd ./xcb-test
        linux-gate.so.1 =>  (0xffffe000)
        libXCB.so.0 => /usr/lib/libXCB.so.0 (0xb7f55000)
        libXCBAux.so.0 => /usr/local/lib/libXCBAux.so.0 (0xb7f53000)
        libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7f40000)
        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7e12000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb7e0f000)
        /lib/ld-linux.so.2 (0xb7f8b000)


$ ls -l  /usr/lib/libXCB*

-rw-r--r--  1 root root 201688 2005-05-08 08:10 /usr/lib/libXCB.a
-rw-r--r--  1 root root    833 2005-05-08 08:10 /usr/lib/libXCB.la
lrwxrwxrwx  1 root root     15 2006-02-05 17:43 /usr/lib/libXCB.so ->
lrwxrwxrwx  1 root root     15 2006-02-05 17:43 /usr/lib/libXCB.so.0 ->
-rw-r--r--  1 root root 156492 2005-05-08 08:10 /usr/lib/libXCB.so.0.0.0

$  ls -l /usr/local/lib/libXCBAux*

-rw-r--r--  1 root root  8420 2006-02-05 18:08 /usr/local/lib/libXCBAux.a
-rwxr-xr-x  1 root root   818 2006-02-05 18:08 /usr/local/lib/libXCBAux.la
lrwxrwxrwx  1 root root    18 2006-02-05 18:08 /usr/local/lib/libXCBAux.so
-> libXCBAux.so.0.0.0
lrwxrwxrwx  1 root root    18 2006-02-05 18:08 /usr/local/lib/libXCBAux.so.0
-> libXCBAux.so.0.0.0
-rwxr-xr-x  1 root root 12125 2006-02-05 18:08

---------------------------------- -----------------------------------------

I have also tried the "Hello World" example from

$ ./hello1
The same result.  It displays some odd characters and blocks.

$ ldd hello1

        linux-gate.so.1 =>  (0xffffe000)
        libXCB.so.0 => /usr/lib/libXCB.so.0 (0xb7ee3000)
        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7db5000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb7db1000)
        /lib/ld-linux.so.2 (0xb7f19000)

This was my first trial, so do not worry,  am very happy with the partial
success so far.

OS: New installment of Ubuntu Linux 5.10
Graphics card:  ATI  Radeon 9800 with OpenGL support defined in xorg.conf

Jamey Sharp wrote:

On Fri, Feb 03, 2006 at 11:16:07PM +0100, Alexander Botero wrote:

1) Is this (xcb) project vivid and active?

XCB development is bursty, mostly because I do most of the work on the
core code and sometimes I go off and work on other projects for a while
instead. However we are making forward progress, and I have some hope
that XCB and Xlib/XCB can be included in the X.org 7.1 release, whenever
that happens.

2) I would like to test your xcb (xlib replacement), but how to start?

First, I hope you understand that XCB itself is not API-compatible with
Xlib, but the Xlib/XCB work exists to provide a drop-in replacement for
Xlib that provides a migration path. So testing XCB itself means either
running our demo applications, or writing some of your own -- which we'd
be happy to help you with.

Unfortunately, I do not fully understand howto install the various parts.

I have read the

and have installed all
pkgconfig 0.15.0,  automake 1.7,  autoconf 2.50,  libtool 1.5.6,  xsltproc,
gperf 3.0.1

aclocal: configure.ac: 14: macro `AM_PATH_CHECK' not found in library

My distro is Ubuntu 5.10 (X86 32 bit)

You should be almost set: you only missed the dependency on 'check'. On
stock Debian testing I can just `apt-get install check`, and I imagine
Ubuntu has a similar package as well.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freedesktop.org/archives/xcb/attachments/20060205/91466216/attachment.html

More information about the Xcb mailing list