[Xcb] naming convention (finished)

Vincent Torri vtorri at univ-evry.fr
Mon Sep 18 23:42:37 PDT 2006

On Mon, 18 Sep 2006, Jamey Sharp wrote:

> We're *almost* there. I'd like my API conversion script to fully agree
> with your XSLT before landing these changes on master, which requires a
> few more minor changes to both tools.

great :)

> You're outputting a couple of functions that weren't produced before:
> xcb_render_query_filters_filters, xcb_xv_mc_list_subpicture_types_types,
> maybe others.

Indeed. I don't understand. Maybe someone should look at the difference 
between the previous xsl and the current one. I have not saved it...

> Your code also seems to have the same trouble as mine does
> with RandR. I haven't looked into why, yet. Probably at this point we
> should hand the XSL off to Josh. I expected to have more work for Josh
> to do than actually remains at this point: you've done a great job with
> a tool you didn't know last week, Vincent! :-)

wel, I used xsl a bit 2 or 3 years ago.

> Anyway, with the above things fixed, there's just minor differences in
> our rules for identifying "words" that should be separated with
> underscores in these names. Hopefully that will be straightforward, but
> we need to decide whether things should be named XCB_MAP_INDEX_1 or
> XCB_MAP_INDEX1, for example.

I prefer the first one because the number is more readable

>>> On Sep 17, 2006, at 2:38 AM, Vincent Torri wrote:
>>>> 4) Because of their name in xproto.xml, some enum values are not
>>>> very good, like XCB_CWBACK_PIXEL. Maybe we should change the name
>>>> so that we obtain XCB_CW_BACK_PIXEL. It's easy to do in xproto.xml
>>>> (changing CW to Cw).
>> it is now handled.
>>>> Also XIDRange to xid_range instead of xidrange.
>> i didn't succeed :/
> I don't understand. Getting CWBack to output CW_BACK should let you make
> XIDRange output xid_range. The rule is exactly the same...

Because CW is the enum name, so I just had to add a space between the name 
and the value names

On the contrary, XID is part of the name GetXIDRange. With the current 
code, I can't isolate XID from that name. Maybe Josh has some ideas about 
how to do that.

>> i've tried to revert my changes. I think i've reverted almost all of them
> You missed one: you had renamed "R" to "r". That's a fine change to
> make, but not right now, and it doesn't affect the API or ABI so it can
> wait until after the release. In the meantime it clutters my diffs...
> :-)

indeed, i've forgotten that one.

> Also, I think you undid too much: I thought you had renamed _iter to
> _iterator already.

No, i've never changed iter into iterator. But it's done, now.

should I send the diff again ?


More information about the Xcb mailing list