[Xcb] naming convention (finished)

Ian Osgood iano at quirkster.com
Tue Sep 19 08:00:57 PDT 2006

On Sep 18, 2006, at 6:00 PM, Jamey Sharp wrote:

> RENDER had a namespace collision prior to this renaming between the
> PictOp enumeration and the PictOp error; my code currently assumes the
> error is what was meant, which is probably the right assumption given
> that programs couldn't actually use the enumeration typename before.

Another way to fix this is to distinguish error codes.  
xcb_bad_pict_op like Xlib is one way.
> Anyway, with the above things fixed, there's just minor differences in
> our rules for identifying "words" that should be separated with
> underscores in these names. Hopefully that will be straightforward,  
> but
> we need to decide whether things should be named XCB_MAP_INDEX_1 or
> XCB_MAP_INDEX1, for example.

I prefer the former. Especially in this example, where another of the  
enumeration values is INDEX_SHIFT.


More information about the Xcb mailing list