[Xcb] naming convention (finished)

Vincent Torri vtorri at univ-evry.fr
Tue Sep 19 23:35:22 PDT 2006

On Tue, 19 Sep 2006, Barton C Massey wrote:

> In message <20060919170526.GA8846 at id.minilop.net> you wrote:
> BTW, I like the proposal of xcb_ for the static part and x_
> for the protocol stuff.  But I'm good with whatever folks
> decide on this score.

We are talking about that for more than 3 days. Let's decide once and for 
all today if we choose x_ or xcb_ for the protocol.

I don't know if my opinion is important, but I was always a bit disturbed 
about the doc on the web site : http://xcb.freedesktop.org/wiki/XcbApi. 
More precisely, I didn't understood first why there were public and 
protocol api, this doc being in the "XCB api" web page. So I would vote 
for xcb_ in all the exported functions in xcb.h, and x_ for all the 
functions in the protocol. That would make clear the fact that each 
function beginning with xcb_ is not part of the protocol, whereas 
functions beginning with x_ is part of the protocol. Maybe that would also 
be clearer for people who use xcb for the first time.

Now let's count the points to see who wins :D


More information about the Xcb mailing list