[Xcb] naming convention (finished)

Keith Packard keithp at keithp.com
Wed Sep 20 00:21:17 PDT 2006

On Wed, 2006-09-20 at 08:35 +0200, Vincent Torri wrote:

> So I would vote 
> for xcb_ in all the exported functions in xcb.h, and x_ for all the 
> functions in the protocol. 

ACK! Please don't mix them. Pick one and stick with it. The separation
isn't useful for users, and will only serve to force them to constantly
refer to the docs to check which prefix is needed for each function.

I'd love to use x_, and I don't know of a package already using it for
function and type names. But, xcb_ would be safer.

keith.packard at intel.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.freedesktop.org/archives/xcb/attachments/20060920/d8a3d579/attachment.pgp

More information about the Xcb mailing list