[Xcb] naming convention (finished)

Jamey Sharp jamey at minilop.net
Wed Sep 20 01:09:33 PDT 2006

On Wed, Sep 20, 2006 at 12:21:17AM -0700, Keith Packard wrote:
> On Wed, 2006-09-20 at 08:35 +0200, Vincent Torri wrote:
> > So I would vote 
> > for xcb_ in all the exported functions in xcb.h, and x_ for all the 
> > functions in the protocol. 
> ACK! Please don't mix them. Pick one and stick with it. The separation
> isn't useful for users, and will only serve to force them to constantly
> refer to the docs to check which prefix is needed for each function.
> I'd love to use x_, and I don't know of a package already using it for
> function and type names. But, xcb_ would be safer.

If people want me to give a decision on this one, I guess I'm inclined
to listen to Keith, despite finding Bernardo, Ian, Bart, and Vincent all
convincing. And since I think the extra two characters won't hurt
anyone, let's go with the full xcb_ prefix everywhere.

Though Keith, I don't think the mixed approach would require looking at
documentation. The twenty-some functions that would have the xcb_ prefix
are all clearly special, as none of them are pure protocol-encapsulation

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.freedesktop.org/archives/xcb/attachments/20060920/08dc4783/attachment.pgp

More information about the Xcb mailing list