[Xcb] [Bug 78081] New: Some programs (emacs, urxvt) hang at xcb_wait_for_event

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Tue Apr 29 06:59:04 PDT 2014


          Priority: medium
            Bug ID: 78081
          Assignee: xcb at lists.freedesktop.org
           Summary: Some programs (emacs,urxvt) hang at xcb_wait_for_event
        QA Contact: xcb at lists.freedesktop.org
          Severity: normal
    Classification: Unclassified
                OS: Linux (All)
          Reporter: n142857 at gmail.com
          Hardware: Other
            Status: NEW
           Version: 1.10
         Component: Library
           Product: XCB

Hi, in last months (early 2014) I started seeing strange hangs in Emacs and
urxvt which I think are due to XCB. I use GNU/Linux Debian with
libxcb1==1.10-2, wmii==3.10~20120413+hg2813-6 window manager.
  The program window becomes black and doesn't react to mouse/keyboard events
or kill signals (I tried many numbers). I have to kill the process (or mess up
gdb until it dies with SIGSEGV). Same for both programs.

*)  Emacs hung. Version: GNU Emacs (x86_64-unknown-linux-gnu, X
toolkit, Xaw scroll bars) of 2014-04-19

(gdb) bt
#0  0x00007f3e744de710 in __poll_nocancel () at
#1  0x00007f3e73fea232 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f3e73febd0f in xcb_wait_for_event () from
#3  0x00007f3e75aa3918 in _XReadEvents () from
#4  0x00007f3e75a8beb1 in XIfEvent () from
#5  0x00007f3e75ad2764 in ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#6  0x00007f3e75ad33c0 in ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#7  0x00007f3e75ad36b1 in _XimRead () from
#8  0x00007f3e75ac2096 in ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#9  0x00007f3e75ab02fd in XSetICValues () from
#10 0x000000000050f099 in xic_set_preeditarea (w=0x5113858, x=768, y=56) at
#11 0x0000000000504c0a in x_draw_window_cursor (w=0x5113858,
glyph_row=0x18039870, x=768, y=56, cursor_type=FILLED_BOX_CURSOR,
cursor_width=1, on_p=true, active_p=true)
    at xterm.c:7312
#12 0x0000000000477484 in display_and_set_cursor (w=0x5113858, on=true,
hpos=96, vpos=4, x=768, y=56) at xdisp.c:27214
#13 0x00000000004f7070 in x_update_window_end (w=0x5113858, cursor_on_p=true,
mouse_face_overwritten_p=false) at xterm.c:582
#14 0x00000000004133ae in update_window (w=0x5113858, force_p=true) at
#15 0x00000000004129f8 in update_window_tree (w=0x5113858, force_p=true) at
#16 0x00000000004129bd in update_window_tree (w=0x524ef10, force_p=true) at
#17 0x00000000004126d1 in update_frame (f=0x5113640, force_p=true,
inhibit_hairy_id_p=false) at dispnew.c:3059
#18 0x000000000044b5ee in redisplay_internal () at xdisp.c:13873
#19 0x00000000004495cd in redisplay () at xdisp.c:13056
#20 0x00000000005292ed in read_char (commandflag=1, map=375333574,
prev_event=12839794, used_mouse_menu=0x7fff8cc0c69f, end_time=0x0) at
#21 0x0000000000534c1a in read_key_sequence (keybuf=0x7fff8cc0c880, bufsize=30,
prompt=12839794, dont_downcase_last=false, can_return_switch_frame=true, 
    fix_current_buffer=true, prevent_redisplay=false) at keyboard.c:9076
#22 0x0000000000526840 in command_loop_1 () at keyboard.c:1449
#23 0x00000000005b3a60 in internal_condition_case (bfun=0x526487
<command_loop_1>, handlers=12890850, hfun=0x525d99 <cmd_error>) at eval.c:1354
#24 0x00000000005261e1 in command_loop_2 (ignore=12839794) at keyboard.c:1174
#25 0x00000000005b3272 in internal_catch (tag=12886738, func=0x5261bb
<command_loop_2>, arg=12839794) at eval.c:1118
#26 0x000000000052618f in command_loop () at keyboard.c:1153
#27 0x0000000000525994 in recursive_edit_1 () at keyboard.c:777
#28 0x0000000000525b01 in Frecursive_edit () at keyboard.c:845
#29 0x0000000000523acf in main (argc=2, argv=0x7fff8cc0cd08) at emacs.c:1654

* urxvt hung. rxvt-unicode==9.19-1. Started with daemon:  urxvtcd

(gdb) bt
#0  0x00007f1b40226710 in __poll_nocancel () at
#1  0x00007f1b3f481232 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f1b3f482d0f in xcb_wait_for_event () from
#3  0x00007f1b4166d918 in _XReadEvents () from
#4  0x00007f1b41655eb1 in XIfEvent () from
#5  0x00007f1b4169c764 in ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#6  0x00007f1b4169d3c0 in ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#7  0x00007f1b4169d6b1 in _XimRead () from
#8  0x00007f1b4168c096 in ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#9  0x00007f1b4167a2fd in XSetICValues () from
#10 0x00000000004281bf in rxvt_term::im_send_spot() ()
#11 0x000000000041e6d9 in rxvt_term::flush() ()
#12 0x0000000000438640 in ev_invoke_pending() ()
#13 0x000000000043989e in ev_run ()
#14 0x0000000000418e87 in main ()

  In addition I'm using scim (input method).

  If there's some way in which I can advance the research of this bug, please
tell me. It happens rarely, maybe once a week. I didn't see any pattern.
  I tried as a workaround to go up the stack and then forcing „return“ in gdb
but it only crashed or hung again. Tips to unblock apps are welcome.

You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/xcb/attachments/20140429/de304794/attachment.html>

More information about the Xcb mailing list