[Xcb] Cannot compile 1.11.1 for arm hosts

Alex Barker alex at 1stleg.com
Sat Feb 13 05:19:09 UTC 2016


I am having quite a bit of trouble compiling libxcb for arm hosts. It 
appears to try and re-link the libxcb-composite.la file against /usr/lib 
during the install phase when cross compiling.  I look thought the 
automake file and it appears to be valid and correct. Libtool should be 
calculating the rpath auto-magically for the libraries in question.  The 
strange part is this use to work, but started failing recently.  I think 
GCC 5.3 was the biggest upgrade. I am looking for any suggestions short 
of patching libtool to get this working.  I have tried rolling back 
package versions for libtool and libxcb with the same result.  
Configuration and error below, full log at: 

--prefix=/usr --build=x86_64-pc-linux-gnu 
--host=armv6j-hardfloat-linux-gnueabihf --mandir=/usr/share/man 
--infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc 
--localstatedir=/var/lib --disable-dependency-tracking 
--disable-silent-rules --libdir=/usr/lib 
--docdir=/usr/share/doc/libxcb-1.11.1-r1 --enable-shared 
--disable-static --disable-devel-docs --disable-selinux --enable-xkb 


make install


libtool: warning: relinking 'libxcb-composite.la' libtool: install: (cd 
--tag CC --mode=relink armv6j-hardfloat-linux-gnueabihf-gcc -Wall 
-Wpointer-arith -Wmissing-declarations -Wformat=2 -Wstrict-prototypes 
-Wmissing-prototypes -Wnested-externs -Wbad-function-cast 
-Wold-style-definition -Wdeclaration-after-statement -Wunused 
-Wuninitialized -Wshadow -Wmissing-noreturn -Wmissing-format-attribute 
-Wredundant-decls -Wlogical-op -Werror=implicit -Werror=nonnull 
-Werror=init-self -Werror=main -Werror=missing-braces 
-Werror=sequence-point -Werror=return-type -Werror=trigraphs 
-Werror=array-bounds -Werror=write-strings -Werror=address 
-Werror=int-to-pointer-cast -Werror=pointer-to-int-cast -march=armv6j 
-Os -mfpu=vfp -mfloat-abi=hard -fomit-frame-pointer -pipe -version-info 
0:0:0 -no-undefined -Wl,-O1 -Wl,--as-needed -o libxcb-composite.la 
-rpath /usr/lib composite.lo libxcb.la -inst-prefix-dir 


/usr/lib/libXau.so: file not recognized: File format not recognized 
collect2: error: ld returned 1 exit status libtool: error: error: relink 
'libxcb-composite.la' with the above command before installing it 
Makefile:849: recipe for target 'install-libLTLIBRARIES' failed make[3]: 
*** [install-libLTLIBRARIES] Error 1 make[3]: *** Waiting for unfinished 


More information about the Xcb mailing list