[Xcb] xcb_poll_for_reply64

Uli Schlachter psychon at znc.in
Wed Nov 23 17:56:45 UTC 2016

On 21.11.2016 17:56, Pierluigi Di Cerbo wrote:
> Hi all
> I am writing since I am almost hopeless
> I have to run a program written by the Sysadmin of the cluster that usually
> I use. when I run it, I get the following error:
> ImportError: /usr/lib/libX11.so.6: undefined symbol: xcb_poll_for_reply64
> I run Arch Linux 4.8.8-2-ARCH
> I am totally sure that the version of libxcb that I installed is the most
> recent one (pacman -Qo /usr/lib/libxcb.so   return  /usr/lib/libxcb.so is
> owned by libxcb 1.12-1 )
> and the same for libX11
> How is it possible??

I don't know why PyInstaller is, but from the web site it sounds like it
is a program that tries to get a program and all of its dependencies
together. I bet that PyInstaller picked up an old version of libxcb and
decided not to pick a suitable version of libX11.

To confirm, I would suggest running 'find /home/vagrant/devel/RCM/ -name
"libxcb*"' to see if it finds some other versions of libxcb.

Q: Because it reverses the logical flow of conversation.
A: Why is putting a reply at the top of the message frowned upon?

More information about the Xcb mailing list