[Xcb] Are there any naming conventions for XCB?

Uli Schlachter psychon at znc.in
Sun Mar 7 08:35:54 UTC 2021


Am 14.02.21 um 23:37 schrieb Lucas:
> I want to introduce one function (another one might be needed) to return
> a xcb_str_t pointer from an iterator because I could not find a function
> to do just that, but I have noticed a pattern in the names of the
> function, hence the question. Here is the function:
> xcb_str_t *xcb_str_iterator_name(xcb_str_iterator_t *iterator)
> {
>     return iterator->data;
> }

Uhm, sorry, but *why*? Can't you just put this function into your own
code with a name of your liking? Why do you think this needs to be in

Also, are you sure the function above really does what you want it to
do? Aren't you instead looking for the already existing xcb_str_name()?

And for the question about naming conventions: Well... kind of. Since
most of the code is automatically generated from an XML description, I
guess "what the code generator does" is the naming convention. It all
maps pretty mechanical to the XML, I think.

This can be a, a little complicated. Listen, my advice is... ask
somebody else for advice, at least someone who's... got more experience
at...  giving advice.

More information about the Xcb mailing list