xfs can't create /tmp/.font-unix dir

Martell, Larry martell at aptec.com
Wed Jul 27 22:13:44 EEST 2005

I am running mandrake linux 10.1 on a system I setup about 1 month ago. 
I have not had any problem on the system until today when the
X server suddenly crashed. When I tried to restart it, it failed with
the messages:
Could not init font element unix/:-1, removing from list!
Fatal server error: could not open default font 'fixed'.
I rebooted, got the same message. I ran the font server in the foreground,
not as a daemon, so I could see it's output. At start up it said:

_FontTransSocketUNIXCreateListener: mkdir(/tmp/.font-unix) failed, errno = 13
_FontTransMakeAllCOTSServerListeners: failed to create listener for local

13 is permission denied, but why would it get this on /tmp, which is world writable:

# ls -la /tmp
total 12
drwxrwxrwt   3 root root 4096 Jul 27 11:04 ./
drwx------    19 root root 4096 Jul 26 15:01 ../
drwxrwxrwt   2 root root 4096 Jul 27 11:00 .X11-unix/

Anyone have any clues?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freedesktop.org/archives/xdg/attachments/20050727/f7210be3/attachment.htm 

More information about the xdg mailing list