hmacht at suse.de
Thu Mar 29 15:00:43 PDT 2007
On Thu 29. Mar - 22:33:35, Richard Hughes wrote:
> On Thu, 2007-03-29 at 23:07 +0200, Holger Macht wrote:
> > > as an option in it's configuration interface. You should be free to
> > do
> > > that in your implementation. The org.fd.PM specification does not
> > > prevent you from such an UI and it shouldn't. This specification
> > should
> > > care about the needs of applications.
> > I fully agree on all this.
> > > (I don't, however, such UI is good UI nor do I think it belongs in
> > > gnome-power-manager. But that's up to Richard and the GNOME project
> > I suppose.)
> > And as a conclusion, if no one else has any comments on this, I think
> > we should let it up to Richard to decide whether to take the Standby()
> > methods or not.
> Well, I respect all of your opinions here, and I think the overall
> consensus is that Standby has no place in the spec.
> I'll rip it out for version 0.2.
> Also, I was advised that GetBatteryState is a pretty bad name. What
> about GetOnBattery or GetBatteryStatus for version 0.2?
I definitely like GetOnBattery more. GetBatteryState or GetBatteryStatus
sounds like you would get different return values depending on, well,
depending on the status the battery is in. Low charge, high charge, etc...
More information about the xdg