JobViewServer specification proposal
senoki at gmail.com
Sat Apr 5 08:29:32 PDT 2008
On Sat, 2008-04-05 at 12:06 +0200, Rafael Fernández López wrote:
> Hi all,
> Comments ? Ideas ? Suggestions ?
"Interface, signal, method, and property names are "WindowsStyleCaps",
note that the first letter is capitalized, unlike Java."
So, it shouldn't it be eg. org.freedesktop.JobView.Terminate instead?
Also, regarding org.freedesktop.JobView.s(S)etTotalAmount; perhaps the
units should be specified in some sort of file format, so that an
application can add new units without requiring going through and
patching the source? This might also make it more reliable across
implementations, as otherwise the KDE implementation might have extra
types that the GNOME implementation doesn't, and vice versa.
More information about the xdg