X Lets Go Of Left Mouse Button When CTRL Key Held Down?

Barry Scott barry.scott at onelan.co.uk
Tue Jan 5 08:26:09 PST 2010

On 26/12/09 00:32, Peter Hutterer wrote:
> On Fri, Dec 25, 2009 at 02:40:31PM -0600, Ole Ersoy wrote:
>> I tried using a Fedora 12 live USB and pressing ctrl still causes the left
>> mouse button to "release".  Then I tried using a different keyboard, and
>> the problem was solved.  So it's my Microsoft Wireless Optical Desktop Pro
>> v2.0 keyboard that's the problem.  Interestingly enough, the problem only
>> occurs while dragging.  For example if I press crtl + w to close a firefox
>> tab, there's no problem.  Any ideas on how to fix this?
> it's likely that your mouse exports keys as well (check the
> /dev/input/eventX kernel device with evtes), hence the mixup in the
> modifiers. I thought that was fixed by now. Please file a bug for this and
> assign it to me, attaching the evtest output for both mouse and keyboard and
> the sequence of events you get in xev when you're trying to cltr+drag.

There are messages sent from the mouse to do with (i'm guessing here)
battery level. What every they are mess up X. I stopped using the Pro V2
for this reason.


More information about the xorg-devel mailing list