eGalax USB Touchscreen support it recent

Peter Hutterer peter.hutterer at
Thu Oct 27 15:06:02 PDT 2011

On Thu, Oct 27, 2011 at 11:09:17AM +0200, Cedric Sodhi wrote:
> Hello,
> I've tried everything I could think of but I cannot get the eGalax
> Touchscreen (ASUS EEE Slate) to work.
> I tried various combinations of the in-kernel eGalax driver (USB
> Touchscreen), the USB HID Multitouch and also the Wacom driver.
> If I interpret it correctly USB HID always wins out, then there is
> /dev/input/event7 in sysfs, which responds fine and even interacts
> (though not correctly) with GPM.
> X also picks the event interface up as a touchscreen and tries to apply
> evdev on it, but although the cursor then moves, it remains practicablly
> unusuable. It's erratic at times, which I suppose happens because evdev
> does not sufficiently smoothen out the coordinates like, say, the
> xf86-input-wacom does (which is a great driver, by the way), and the
> coordinates to not map at all.
> It appears that, though XOrg says the axes were absolute, it becomes
> some kind of unpredictable mapping because there is also some sort of
> acceleration taking place.
> So if I, say, *touch* the screen at certain position, the cursor
> reproducably jumps to a specific position. But if I drag arround on the
> screen, there is no 1-to-1 correspondance between position on screen and
> position on display.
> Clicking also doesn't work at all. And when I try to set the "evdev
> calibration", it has absolutly no effect whatsoever (from within
> xorg.conf and xinput extension cli alike).

please file a bug, assign it to me and attach your xorg.log, xorg.conf (if
any) and the evtest output for this device (bonus points for evtest-capture
output so I can reproduce it here)


More information about the xorg-devel mailing list