Xorg 6.8.1 Locks system when run - "Caught signal 11. Server aborting"

Nicholas Devenish ned20 at sussex.ac.uk
Mon Oct 18 12:38:18 PDT 2004


I have been trying to upgrade my current version of Xorg (Xorg -version 
says release 6.7) to the latest stable CVS.

I got through all the compiling stages without any obvious errors, and 
installing it went fine. I then tried 'startx' from root, and it was a 
little slow, but ran and started gnome fine.

I then changed to init 5, and the login screen started up, but when I 
went to log in under my normal user, the screen flickered a few times 
then dropped back to the logon screen. I tried again, but this time when 
it dropped back to the logon screen it locked up completely, not even 
allowing me to force a quit or switch to another virtual terminal.

After restarting, I tried 'startx' from my normal user login. It loaded 
the splash screen, then just locked and stopped responding again.

On examination of the Xorg.log (attached) it has this line near the end:
        Fatal server error:
        Caught signal 11.  Server aborting

and no other obvious errors during the rest of the log that I can see. I 
have found several references to "Signal 11", but it's all people using 
nvidia drivers, and I'm using an ATI card.

Many thanks for any help you can provide,

      Nicholas Devenish

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: Xorg.0.log.old
URL: <http://lists.x.org/archives/xorg/attachments/20041018/d2b03b3b/attachment.ksh>

More information about the xorg mailing list