Xorg 6.8.1 Locks system when run - "Caught signal 11. Server aborting"

Vladimir Dergachev volodya at mindspring.com
Mon Oct 18 14:39:58 PDT 2004

It looks like you are using fglrx driver - I don't think this is 
compatible with latest CVS. I might be wrong though..


                         Vladimir Dergachev

On Mon, 18 Oct 2004, Nicholas Devenish wrote:

> Hi,
> I have been trying to upgrade my current version of Xorg (Xorg -version says 
> release 6.7) to the latest stable CVS.
> I got through all the compiling stages without any obvious errors, and 
> installing it went fine. I then tried 'startx' from root, and it was a little 
> slow, but ran and started gnome fine.
> I then changed to init 5, and the login screen started up, but when I went to 
> log in under my normal user, the screen flickered a few times then dropped 
> back to the logon screen. I tried again, but this time when it dropped back 
> to the logon screen it locked up completely, not even allowing me to force a 
> quit or switch to another virtual terminal.
> After restarting, I tried 'startx' from my normal user login. It loaded the 
> splash screen, then just locked and stopped responding again.
> On examination of the Xorg.log (attached) it has this line near the end:
>       Fatal server error:
>       Caught signal 11.  Server aborting
> and no other obvious errors during the rest of the log that I can see. I have 
> found several references to "Signal 11", but it's all people using nvidia 
> drivers, and I'm using an ATI card.
> Many thanks for any help you can provide,
>     Nicholas Devenish

More information about the xorg mailing list