Compiling troubles

Stefano Semeria sithlord81 at
Sat Sep 4 05:36:57 PDT 2004

Hi, I'm having troubles compiling xorg 6.7.0 from CVS.
>From the beginning,  I've got an Asus L2000D laptop with a SiS 300 chipset
which should have hardware acceleration. I ' ve first used xorg deployed
with Linux Slackware 10, but no luck in making DRI work (GL apps
By the way, I'm using 2.6.7 kernel that I've compiled with DRM, AGP and
framebuffer compiled in the kernel (not as modules) and gcc 3.3.4. I've
tried downloading xorg sources from CVS, and without changing the default
configuration when I run "make World" I get the following error from make:

make[3]: Leaving directory `/root/xc/lib/Xext'
including in lib/Xt...
make[3]: Entering directory `/root/xc/lib/Xt'
rm -f StringDefs.c StringDefs.h Shell.h
../../config/util/makestrs  < util/string.list > StringDefs.c
make[3]: *** [Shell.h] Error 139
make[3]: Leaving directory `/root/xc/lib/Xt'
make[2]: *** [includes] Error 2
make[2]: Leaving directory `/root/xc/lib'
make[1]: *** [includes] Error 2
make[1]: Leaving directory `/root/xc'
make: *** [World] Error 2

Can anybody help me? (By the way, I'm using CVS cause the Slackware sources
seem to lead to the same problem).
Can also anyone tell me when xorg 6.8 will be stable??

More information about the xorg mailing list