modular build issues (savage and xkb)

Georgi Hristov georgi at
Tue Sep 13 05:01:32 PDT 2005


>Your previous Xorg version did not have DRI-support for Savage. But your
>log indicates that you don't have DRI enabled, so this can't be the
>problem. I can't find any hint in your log as to why Xvideo isn't
>working. What do "xdpyinfo" and "xvinfo" say?
xvinfo says "no adaptors found", and i've attached the output of xdyinfo.
The problem however seems to be in the modular build, as i've tried 
plugging a savage driver from a monolithic build from today in my 
modular build from last week, and Xvideo works just fine. So I guess the of the driver in the modular tree is not defining something 
or I dont know what.
I hope I'm not the only person using savage with a modular build, since 
I'm not much into autoconf and family (or any other build system for 
that matter), but maybe I'll have to learn at least a bit to fix this.

>>And to the point about VT switching - I've built cvs version from 7.Sep, 
>>so the patch in libX11 must be there already, and yet it doesn't work 
>>for me.
>>Neither is the xkb switching.
>Try Donnie Berkholz' suggestions for these issues. He only replied to
>the list. Are you subscribed?
Sorry for this, yes, I'm subscribed and this message is to the list, I 
just didn't bother to reply to Donnie Berkholz in a separate message. 
Anyway, I tried what he suggested without much of a difference.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: xdpyinfo.log
URL: <>

More information about the xorg mailing list