not possible to start two X servers, only the one launched later works

Zhang Weiwu zhangweiwu at
Sat Jun 3 10:42:39 PDT 2006

On Sat, 3 Jun 2006, Stefan Dirsch wrote:

> On Sun, Jun 04, 2006 at 12:53:06AM +0800, Zhang Weiwu wrote:
> > I just realized -novtswitch and -sharevts are new options added for Xorg
> > 6.9/7.x
> See my mail before.
> > I tried this option on Xorg 6.8.2 on Ubuntu and it works, Ubuntu must have
> > 6.8.2 patched.
> Sure, this would be possible. AFAIK Ubuntu is pretty well prepared for
> Multiseat since some time.
> > For SuSE even 6.9.0 doesn't have this option. That's not surprising.
> I think you're wrong.

It is very clear native package Xorg 6.9.0 on SuSE 10.1 and native package
Xorg 6.8.2 on SuSE 10.0 either do not have this option, or have it disabled
by some means. Even if I misspelled it in mail doesn't mean I didn't read
these options on the Internet and tried. We got a lot of SuSE computers in
the office to try this. Both -sharevts and -novtswitch produce Fatal error
of "unrecongnized option", so doesn '-isolatedDevice'.  Now I am really
interested in how to find a package with these options enabled.  Is the RPM
package attached to the bug you mensioned earlier having this fix?

> > I
> > always have the impression that when Ubuntu said it's version a.b.c actually
> > it is using a.b.c+1 because they get it patched, and for SuSE when they say
> > it is a.b.c actually it is using a.b.c-1 because they used PRE/RC version
> > (the story of SuSE 10.0 with OOO 2.0 is an example).
> Well, that's your opinion. No need to discuss this.

Ah, I am glad if this impression is wrong, the whole office is equipped with
SuSE already.

> > I just find it difficult to google out an xorg 7.0 RPM for SuSE 10.1
> > or SuSE 10.0
> X.Org 6.9/7.0 is exactly the same code base. Only the build
> differs. SUSE 10.1 will ship X.Org >= 7.1.

More information about the xorg mailing list