not possible to start two X servers, only the one launched later works

Zhang Weiwu zhangweiwu at
Sat Jun 3 10:52:18 PDT 2006

On Sun, 4 Jun 2006, Zhang Weiwu wrote:

> On Sat, 3 Jun 2006, Stefan Dirsch wrote:
> > On Sun, Jun 04, 2006 at 12:53:06AM +0800, Zhang Weiwu wrote:
> > > I just realized -novtswitch and -sharevts are new options added for Xorg
> > > 6.9/7.x
> >
> > See my mail before.
> >
> > > I tried this option on Xorg 6.8.2 on Ubuntu and it works, Ubuntu must have
> > > 6.8.2 patched.
> >
> > Sure, this would be possible. AFAIK Ubuntu is pretty well prepared for
> > Multiseat since some time.
> >
> > > For SuSE even 6.9.0 doesn't have this option. That's not surprising.
> >
> > I think you're wrong.
> It is very clear native package Xorg 6.9.0 on SuSE 10.1 and native package
> Xorg 6.8.2 on SuSE 10.0 either do not have this option, or have it disabled
> by some means. Even if I misspelled it in mail doesn't mean I didn't read
> these options on the Internet and tried. We got a lot of SuSE computers in
> the office to try this. Both -sharevts and -novtswitch produce Fatal error
> of "unrecongnized option", so doesn '-isolatedDevice'.  Now I am really
> interested in how to find a package with these options enabled.  Is the RPM
> package attached to the bug you mensioned earlier having this fix?

Ah, I am very sorry for this wrong information. I just sshed to the nearby
office to check this option when I think the admins updated the whole of
that office to 10.1 already. After I sent the mail, just to be careful I
went to that office double-checked and obviously the admins DIDN'T upgraude
the hosts to 10.1, they were still 10.0. I tried on a REAL 10.1 computer and
it is true 10.1 have -sharevts option. This is an obvious mistake and I

And I didn't notice you were from SuSE. Forget any stupid comments about
SuSE I made:)

More information about the xorg mailing list