R3XX lockup possible solution

Jerome Glisse j.glisse at gmail.com
Sun Jun 25 05:28:43 PDT 2006

On 6/25/06, Peter Zubaj <pzubaj at gaya.sk> wrote:
> Hi,
> I tested this on my card.
> 01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R300 NE
> [Radeon 9500 Pro] (prog-if 00 [VGA])
>         Subsystem: ATI Technologies Inc Radeon R300 NE [Radeon 9500 Pro]
>         Flags: bus master, stepping, 66MHz, medium devsel, latency 255,
> IRQ 21
>         Memory at d0000000 (32-bit, prefetchable) [size=128M]
>         I/O ports at c800 [size=256]
>         Memory at dfef0000 (32-bit, non-prefetchable) [size=64K]
>         Expansion ROM at dfec0000 [disabled] [size=128K]
>         Capabilities: <access denied>
> First, I think, you shouldn't touch register 0x140, you write value 0x22
> there. For my card there is 0x2D (this is power on default and is not
> changed by fglrx). When value 0x22 is written there, I have got
> corrupted console and X desktop too.

Yes, there is lot useless things in r300init...

> Basically I tried ut2004. With ColorTiling On. Without you fix computer
> locked immediately (on game start, or in game menu). With this fix I was
> able to play ut2004 for more then 10 minutes (without lock - for now I
> don't have time to test more). I will try to compare other values with
> values from dump from my card.

If you have time to let it play longuer (on my computer i run it in windowed
and spectate mode). If you compare to dump of your card make sure fglrx
kernel module isn't loaded and look around line 440 in dump, this were
should the key things happen which is i think write 0x0008BBBB to 0x0118.

Jerome Glisse

More information about the xorg mailing list