can't use neomagic driver

Thibaud Hulin hulin.thibaud at
Sat Feb 10 02:22:08 PST 2007

Hi !

With an edgy, I can't use neomagic driver in /etc/X11/xorg.conf, only 
vesa driver. I don't think it's normal, because I already use the 
neomagic driver with this PC.
I've got a neomagic pci card, NM2160 MagicGraph 128XD, with a kernel 2.6.19.
So, with this driver, I many problems : contrast when I get to a tty 
console (alt-f1) and return to X, problems of hibernation, and maybe 
perform for video (I can't use x11 with mplayer).
I tried X from a server version of ubuntu like that :
# apt-get install xorg xserver-xorg gsfonts-x11 msttcorefonts 

I've got problems of fonts too, I get these error messages :
Could not init font path element /usr/share/fonts/X11/TTF et aussi OTF 
et CID
FreeFontPath: FPE "/usr/share/X11/fonts/misc" refount is 2, should be 1; 

I checked I've got installed xserver-xorg-video-neomagic.
What's wrong ?

Finally, I tried to install X by sources, but I couldn't get a howto, 
and the installation failed.

Sure, X works, but I can have a little more, can't I ?

Thanks for help,

More information about the xorg mailing list