can't use neomagic driver

Thibaud Hulin hulin.thibaud at
Mon Feb 12 08:53:31 PST 2007

This is my /varlog/Xorg.0.log. Nobody has an idea ?

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux i686
Current Operating System: Linux dell 2.6.1920070212 #1 Mon Feb 12 
15:03:31 CET 2007 i586
Build Date: 07 July 2006
	Before reporting problems, check
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Feb 12 17:46:33 2007
(==) Using config file: "/etc/X11/xorg.conf"
Data incomplete in file /etc/X11/xorg.conf
	Undefined Device "Ecran generique" referenced by Screen "Default Screen".
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
no screens found
(WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
(WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor
(WW) xf86OpenConsole: VT_GETSTATE failed: Bad file descriptor

Thibaud Hulin a écrit :
> Hi !
> With an edgy, I can't use neomagic driver in /etc/X11/xorg.conf, only 
> vesa driver. I don't think it's normal, because I already use the 
> neomagic driver with this PC.
> I've got a neomagic pci card, NM2160 MagicGraph 128XD, with a kernel 
> 2.6.19.
> So, with this driver, I many problems : contrast when I get to a tty 
> console (alt-f1) and return to X, problems of hibernation, and maybe 
> perform for video (I can't use x11 with mplayer).
> I tried X from a server version of ubuntu like that :
> # apt-get install xorg xserver-xorg gsfonts-x11 msttcorefonts 
> x-window-system
> I've got problems of fonts too, I get these error messages :
> Could not init font path element /usr/share/fonts/X11/TTF et aussi OTF 
> et CID
> FreeFontPath: FPE "/usr/share/X11/fonts/misc" refount is 2, should be 1; 
> fixing
> I checked I've got installed xserver-xorg-video-neomagic.
> What's wrong ?
> Finally, I tried to install X by sources, but I couldn't get a howto, 
> and the installation failed.
> Sure, X works, but I can have a little more, can't I ?
> Thanks for help,
> Thibaud.

More information about the xorg mailing list