Keyboard switching problems in Xorg on gentoo

plhu plhu at
Tue Jul 17 11:43:52 PDT 2007

I am unabl to make xkb to switch two diferent layouts on my gentoo box. I  
tried to change xorg.conf according to advices of documentation and some  
of conferences, but the problem persists. I asked this question on gentoo  
forum and I do not have further ideas where to ask for help or how to  
debug. The problem is perhaps i xkb related software as I am not able to  
switch eg on gkrellm plugin and if in gnome, error is reported. I tried to  
rebuild all xkb-relaetd packages, but it is still the same. I attach my  
xorg.conf (commented lines show what I tried). Fortunately setxkbmap us  
works well.
   Any advice or some point to relevant documentation appreciated.


My box is amd64 gentoo (x11-base/xorg-server 1.2.0-r3, x11-base/xorg-x11  
7.2, all stable compiled with these USE flags (-3dfx debug -dmx dri  
-input_devices_acecad -input_devices_aiptek -input_devices_calcomp  
-input_devices_citron -input_devices_digitaledge -input_devices_dmc  
-input_devices_dynapro -input_devices_elo2300 -input_devices_elographics  
input_devices_evdev -input_devices_fpit -input_devices_hyperpen  
-input_devices_jamstudio -input_devices_joystick input_devices_keyboard  
-input_devices_magellan -input_devices_microtouch input_devices_mouse  
-input_devices_mutouch -input_devices_palmax -input_devices_penmount  
-input_devices_spaceorb -input_devices_summa input_devices_synaptics  
-input_devices_tek4957 -input_devices_ur98 -input_devices_vmmouse  
-input_devices_void -input_devices_wacom ipv6 -kdrive -minimal nptl sdl  
-video_cards_apm -video_cards_ark -video_cards_chips -video_cards_cirrus  
-video_cards_cyrix -video_cards_dummy -video_cards_epson  
-video_cards_fbdev -video_cards_fglrx -video_cards_glint -video_cards_i128  
-video_cards_i740 -video_cards_i810 -video_cards_impact -video_cards_imstt  
-video_cards_mach64 -video_cards_mga -video_cards_neomagic  
-video_cards_newport -video_cards_nsc video_cards_nv video_cards_nvidia  
-video_cards_r128 -video_cards_radeon -video_cards_rendition  
-video_cards_s3 -video_cards_s3virge -video_cards_savage  
-video_cards_siliconmotion -video_cards_sis -video_cards_sisusb  
-video_cards_sunbw2 -video_cards_suncg14 -video_cards_suncg3  
-video_cards_suncg6 -video_cards_sunffb -video_cards_sunleo  
-video_cards_suntcx -video_cards_tdfx -video_cards_tga  
-video_cards_trident -video_cards_tseng video_cards_v4l video_cards_vesa  
-video_cards_vga -video_cards_via -video_cards_vmware -video_cards_voodoo  
xorg xprint))
uname -a
Linux localhost 2.6.20-gentoo-r7 #14 Fri Jun 29 22:14:19 CEST 2007 x86_64  
AMD Athlon(tm) 64 Processor 3400+ AuthenticAMD GNU/Linux
-------------- next part --------------
A non-text attachment was scrubbed...
Name: xorg.conf
Type: application/octet-stream
Size: 4384 bytes
Desc: not available
URL: <>

More information about the xorg mailing list