Can't set 1440x900 at 60Hz on i945G

eguizabal carlos ceguizabal at
Tue Sep 11 13:21:26 PDT 2007


Recently intalled SuSE 10.2 on a machine with an i945G and a "wide screen"
monitor (HP- W1907).

The problem is I can't set the recommended resolution of 1440x900. I'm
forced to use 1280x1024 at 75 and end up with a horizontally distorted

Sys info:
   X Windows sys v.6.9.0
   X Protocol v11, Rev 0, Rel 6.9
   i810 driver

I tried xrandr but the desired resolution is not listed. Tried compiling
version 1.2 of this tool but got errors.

I've been reading in some forums but my experience with X is limited to
fiddling a little with the configuration file.

Help please. I'm not sure what to do. Should I continue with xrandr new
version? Replace i810 for the new intel driver 2.x? 

Or perhaps it'll be better to install X anew from scratch(X11R7.3)? Can
this be done in a prepackaged sys like openSuSE?

Thanks in advance.

Take the Internet to Go: Yahoo!Go puts the Internet in your pocket: mail, news, photos & more.

More information about the xorg mailing list