Can't set 1440x900 at 60Hz on i945G

Wu, Nian nian.wu at
Tue Sep 11 23:41:43 PDT 2007

eguizabal carlos wrote:
> Greetings.
> Recently intalled SuSE 10.2 on a machine with an i945G and a "wide
> screen" 
> monitor (HP- W1907).
> The problem is I can't set the recommended resolution of 1440x900. I'm
> forced to use 1280x1024 at 75 and end up with a horizontally distorted
> screen.
> Sys info:
>    X Windows sys v.6.9.0
>    X Protocol v11, Rev 0, Rel 6.9
>    i810 driver

915resolution may be helpful to you.

> I tried xrandr but the desired resolution is not listed. Tried
> compiling 
> version 1.2 of this tool but got errors.

To update xrandr 1.2, you also need update libXrandr, randrproto,
xserver and video driver.

> I've been reading in some forums but my experience with X is limited
> to 
> fiddling a little with the configuration file.
> Help please. I'm not sure what to do. Should I continue with xrandr
> new 
> version? Replace i810 for the new intel driver 2.x?

Xrandr1.2 can support 1440x900, which need xserver 1.3 and
xf86-video-intel 2.0 or above.

More information about the xorg mailing list